Azure Data Factory Self Hosted Integration Runtimes Issues

Humberto Della Torre 1 Reputation point
2021-12-01T15:52:45.537+00:00

I have a self hosted integration runtime to connect an on prem Oracle DB to my Data Factory. The setup seems to work correctly I am able to connect to the database and create datasets and select my tables for lets say a copy activity.

The issue comes in that the service is constantly becoming unavailable, it seems that when available and used it takes a couple of minutes before the service stops and the integration runtime on the on prem machine shows that it is trying to reconnect. I ran the troubleshooting in the Integration Runtime application on the on prem computer and it seems to have issues with "Get service endpoint certificate information" and "Connecting to cloud service endpoint".

Would anyone have a clue on why the integration runtime shows this behavior?

Additionally if I have only one node at the moment does a certificate serve a purpose or is it just recommended once more nodes are active?

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,137 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. KranthiPakala-MSFT 46,407 Reputation points Microsoft Employee
    2021-12-03T00:08:25.12+00:00

    Hi @Humberto Della Torre ,

    Welcome to Microsoft Q&A forum and thanks for posting your query.

    Could you please double check if your On Prem server meets the SHIR pre-requisites.

    The recommended minimum configuration for the self-hosted integration runtime machine is a 2-GHz processor with 4 cores, 8 GB of RAM, and 80 GB of available hard drive space. For the details of system requirements

    I would also recommend you to please review the SHIR - Prerequisites

    Also please refer to this troubleshooting guide doc and see if that helps - Troubleshoot self-hosted integration runtime

    It's really hard to predict what could be the reason for this behavior as SHIR is managed by user and many factors can cause this issue. I would recommend you to file a Support ticket so that a Support engineer can collect necessary logs from you to have deeper look and provide the exact root cause details and resolution for the issue. In case if you don't have support please let us know here.

    Thank you


  2. Jakub Skibicki 1 Reputation point
    2022-03-11T21:13:54.447+00:00

    I have same issue. I would very much like to get any advice.

    0 comments No comments