SQL and SSAS and cubes Processing via job

Lionel Folkes 1 Reputation point
2021-12-03T18:53:35.68+00:00

Hello am trying to create a job to process my default/customized cubes however, each time the job runs it gives me this error:
"Message
[136] Job DailyProcesCubes reported: <return xmlns="urn:schemas-microsoft-com:xml-analysis"><results xmlns="http://schemas.microsoft.com/analysisservices/2003/xmla-multipleresults"><root xmlns="urn:schemas-microsoft-com:xml-analysis:empty"><Exception xmlns="urn:schemas-microsoft-com:xml-analysis:exception" /><Messages xmlns="urn:schemas-microsoft-com:xml-analysis:exception"><Error ErrorCode="3239575556" Description="Either the 'domain\DB$' user does not have permission to process the 'Budget control cube' object, or the object does not exist." Source="Microsoft SQL Server 2012 Analysis Services" HelpFile="" /></Messages></root></results></return>
"
if I log unto SSAS server and process the cube manually it worked fine. Completes without problem. I want to set it to run automatically because the cubes are to refresh/process every 15 minutes.

And help how to resolve the problem above would be greatly appreciated.

SQL Server Analysis Services
SQL Server Analysis Services
A Microsoft online analytical data engine used in decision support and business analytics, providing the analytical data for business reports and client applications such as Power BI, Excel, Reporting Services reports, and other data visualization tools.
1,231 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. CarrinWu-MSFT 6,836 Reputation points
    2021-12-06T01:58:08.097+00:00

    Hi @Lionel Folkes ,

    Welcome to Microsoft Q&A!

    Description="Either the 'domain\DB$' user does not have permission to process the 'Budget control cube' object, or the object does not exist."

    The 'domain\DB$' user don’t have sufficient permission to run cubs. For detailed information, please refer to Grant cube or model permissions (Analysis Services).
    155106-1.png
    155132-2.png
    155107-3.png

    Best regards,
    Carrin


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Lionel Folkes 1 Reputation point
    2021-12-06T17:22:24.89+00:00

    Hi Thanks for your help. I would have done all of this already. I have created a group and allow the group to have full permission to process cube but its still not working. I am also sing the service account..please note this is something that used to work in the past.

    0 comments No comments

  3. CarrinWu-MSFT 6,836 Reputation points
    2021-12-07T06:01:40.75+00:00

    Hi @Lionel Folkes ,

    I reproduced a similar error and solved by below steps, hope it can help you.
    155537-error.png

    1. Open SQL Server Configuration Manager, check the SQL Server Agent Account Name:
      155538-4.png
    2. Add the SQL Server Agent Account Name to Analysis Service Properties - Server administrators:
      155544-5.png
    3. Right click the cube which you want to schedule it, and the select Process. Cope the XLMA script:
      155539-6.png
    4. Create a job as below:
      155509-7.png
      155545-8.png
    5. Success
      155498-result.png
    0 comments No comments