office 365 autocomplete

support001 1 Reputation point
2021-12-08T19:29:09.787+00:00

deleting email address from autocomplete recent people is not working. if i delete an entry it shows up the next day.
is there a way to fix this without deleting and recreating the stream_autocomplete...dat roam cache?

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,720 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Faery Fu-MSFT 15,506 Reputation points Microsoft Vendor
    2021-12-09T06:59:50.537+00:00

    Hi @support001 ,
    To verify your issue, are you using Outlook Client?
    If so, you can switch Outlook to Online mode and see if it works.
    File > Account settings > Account settings > Select your Exchange Account > Change > Uncheck Use Cached Exchange Mode
    156202-switch.png
    Besides, given that only deleting an entry is not working, it is recommended that you empty the auto-complete list to see if the issue continues.
    File > Options > Mail > Empty Auto-Complete List
    156175-empty-autocomplate.png

    is there a way to fix this without deleting and recreating the stream_autocomplete...dat roam cache?

    I’m afraid it is not feasible.
    Outlook caches autocomplete streams locally in Stream_Autocomplete*.dat file, and with only one .dat file per configured account.
    According to my test, when I empty Auto-complete List, the .dat file is automatically deleted.
    156221-stream1.png
    156222-stream2.png


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread. 

    1 person found this answer helpful.