I can't Install Visual Studio 2022 [NOT SOLVED]

asked 2021-12-21T22:03:58.353+00:00
ImVulpi 26 Reputation points

When I try to open downloaded vs/community the problem occurs, in first
seconds it's normally downloading but then it closed and nothing else happened.

This is screenshot of the loading screen:
][2]

I did read this: https://learn.microsoft.com/en-us/answers/questions/624868/i-can39t-install-visual-studio-2022-when-i-open-th.html
Which wasn't helpful.
I found an error in %temp% files
it's an code 0x0 and 0x1389
Here it is ![159467-image.png][3] [3]: /api/attachments/159467-image.png?platform=QnA

I did try to install it (failed)
I did try to reinstall it (failed)
I did try to restart my computer then install it (failed)
I did checked and updated my windows (still couldn't install it)
I did run "sfc /scannow" in CMD as an admin (it fixed my corruption in system files, but still couldn't install it even after restarting my computer.)
My instaler is in disc Windows(C):
I tried to move it into another disc and run it there (failed)
When I tried to instal Build Tools because I was thinking it might help (Coudn't instal same code errors as above /)(so maybe it's a problem with installers)
Yes i runned a windows troubleshooter a lot of times.
I tried to instal it with Chocolatey, that also didn't work because of the same problem.
I had VS 2019 And I deleted it. also did delete other VS 2019 folders. Reason: It was broken, that's why i tried to reinstal it. and I mean whole Instaler was broken.
I checked Visual Studio 2022 System Requirements, should run perfectly.
I tried to run VS 2019 because i was 100% sure my sestem requirements could launch it because I had it before and it was working just good. (result: couldn't install it. same code error as above)
I cleaned my %temp% then restarted computer then I re-downloaded the Visual Studio from the download page then I launch it as a admin (Couldn't install it same code error.)
My antivirus doesn't block it. I checked my quarantine twice or more. nothing was blocked, My antivirus is setup to ask me if i want to block apps so i would know but i still checked it.
I restarted it, and when I launch the Installer it doesn't work

I dont know what to do know. Im out of Ideas.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,388 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
694 questions
No comments
{count} votes

5 answers

Sort by: Most helpful
  1. answered 2021-12-22T06:18:07.263+00:00
    Anna Xiu-MSFT 11,006 Reputation points Microsoft Employee

    Hi @ImVulpi ,

    Welcome to Microsoft Q&A!

    What is your Windows version? Could you try to run the vs_installershell.exe file to launch the Visual Studio Installer: C:\Program Files (x86)\Microsoft Visual Studio\Installer?

    If it doesn’t work, please right-click on .exe file > Properties > Compatibility > set the compatibility mode to “Windows 8” to run it again.

    Sincerely,
    Anna
    *
    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. answered 2021-12-26T22:41:38.633+00:00
    EK 1 Reputation point

    I tried to add Python to Visual Studio Community 2022 and the installer is completely broken. I always get notification
    "Sorry, something went wrong"
    I tried to repair/unistall/install fresh copy of VS Community 2022 but it does not work.
    I wasted 2 hours, and it is really frustrating.
    I have Win 21H1 x64 and VS 2022 Community ver, 17.0.4

    No comments

  3. answered 2022-01-27T16:11:45.257+00:00
    ImVulpi 26 Reputation points

    hello?
    will it be resolved by someone?

    No comments

  4. answered 2022-01-27T19:19:57.537+00:00
    EK 1 Reputation point

    I uninstalled VS 2022 and re-installed back VS 2019. This was my "resolution" of the problem.


  5. answered 2022-11-25T11:50:25.2+00:00
    Vu Vo 1 Reputation point

    Hi there, I'm having the issue where the laucher did NOT launch, tried everything the original author suggested, also from some research like this but no luck.
    installer older version of VS did not help either, I feel like Im getting to the point of reset my entire Windows Operating System! Any1 had any luck??

    https://stackoverflow.com/questions/42755939/visual-studio-2017-install-break-it-not-get-start/43051252#43051252
    https://social.msdn.microsoft.com/Forums/en-US/407f260d-c8f9-4545-bb76-77121a533d00/cant-launch-visual-studio-installer-?forum=vssetup

    264185-vs-cannot-install.png

    No comments