Error "An authentication error has occurred (Code: 0x800706be)" when trying to use Remote Desktop to connect in Windows 10

Hruby, Jan 1 Reputation point
2022-01-25T09:24:04.913+00:00

I saw the same article for Windows 11, however I experience this problem on Windows 10. What did I do

  • install Azure Remote Desktop on my Windows 10 machine (latest update)
  • logged into my company workspace using my company MS account
  • tried to login to my remote VM
  • I get an error message - An authentication error has occurred (Code: 0x800706be)
  • cherry on top, this is my personal notebook. On my office computer I can access the VM just fine. Same installation of Windows and Azure Remote Desktop

what can be wrong?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,553 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,225 questions
{count} votes

9 answers

Sort by: Most helpful
  1. VINCENZO MOIOLI 30 Reputation points
    2023-05-21T12:46:51.88+00:00

    The simple fix is to head to C:\Program Files\CSR\CSR Harmony Wireless Software Stack

    rename

    BLEtokenCredentialProvider.dll to

    BLEtokenCredentialProvider.dll.BAK

    6 people found this answer helpful.

  2. Radu Dredetianu 6 Reputation points
    2022-05-02T06:08:47.197+00:00

    i have same issuse in win11 after update in 29.04.2022,
    i resolved with
    ”sfc /scannow”

    C:\Windows\system32>sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection found corrupt files and successfully repaired them.

    1 person found this answer helpful.

  3. Baba 5 Reputation points
    2023-11-10T15:38:12.6633333+00:00

    Had this happen to me and its easy to overlook. Make sure you don't have a cached account name in the account box. In my case somehow and oldcomputername\account (or olddomain\account) was in the rdp cached credential box and it was giving this error. Instead of using command line to login, used the ui, click on show options and changed username to .\account and was immediately prompted for the password and was able to login.

    Hope this helps.

    1 person found this answer helpful.

  4. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.

    1 deleted comment

    Comments have been turned off. Learn more

  5. Limitless Technology 39,331 Reputation points
    2022-01-25T17:28:38.68+00:00

    Hi there,

    This issue has been faced by users and some have stated SFC has sorted this issue. You can also repair update the PC and this will sort the Issue.

    Here is a thread as well that discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue.

    Error "An authentication error has occurred (Code: 0x800706be)" when trying to use Remote Desktop to connect in Windows 11.
    https://learn.microsoft.com/en-us/answers/questions/516232/error-34an-authentication-error-has-occurred-code.html

    RDP authentication error code 0x800706be
    https://answers.microsoft.com/en-us/windows/forum/all/rdp-authentication-error-code-0x800706be/05cecb18-19ba-442f-ab3b-67a3b73f86d8

    ----------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments