Exchange 2013 cannot get "+" to work on email addresses, send connectors, etc

Ron H 21 Reputation points
2022-01-27T23:02:56.95+00:00

This is really strange. I am reinstalling Exchange Server 2013 on a clean os / domain. I ran all he prereq and install steps and everything shows no errors. I have all the tools and can get into EAC no problem. However, in many places the "+, pencil (Edit), and - icons do nothing when clicked. For example, under recipient email addresses when I click "+ " it does nothing and will not let me add a new email address. Under send connectors, i can use the "+" create the new connector, but the "+" under address space for MX record does nothing. Has anyone seen this and can you offer a fix?
Thanks in advance.

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,873 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,335 questions
{count} votes

Accepted answer
  1. Aaron Xue-MSFT 2,581 Reputation points Microsoft Vendor
    2022-01-28T02:54:20.727+00:00

    Hi @Ron H ,

    I think this problem may be caused the cookies and cache.

    You could tried to clear the cookies and check it the issue has been solved.

    What's your windows sererver version?

    According to this document.
    https://learn.microsoft.com/en-us/exchange/architecture/client-access/exchange-admin-center?view=exchserver-2016#supported-browsers

    Google Chrome and Edge are not supported on Windows Server 2012 R2.
    169283-1.png

    I would recommend to use IE to manage the EAC to have a better experience.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1 additional answer

Sort by: Most helpful
  1. Ron H 21 Reputation points
    2022-01-28T02:08:38.983+00:00

    I have tried with Chrome and Edge. But based on your suggestion I just tried IE and that worked. Any idea why Chrome and Edge do not work?

    0 comments No comments