Visual C++ vc_runtimeminimum_x64.msi Error

Will V 11 Reputation points
2020-08-20T00:30:53.597+00:00

When trying to uninstall Visual C++ I get the following error:

18936-ctroubleshoot.jpg

Here are the remaining versions of Visual C++ on my device:

18837-ctroubleshoot2.jpg

When trying to install the latest Visual C++ I get this error:

18897-ctroubleshoot3.jpg

I attempted to use the Program Install and Uninstall troubleshooter from Microsoft, but the download link is broken. How can I proceed? I need to fix this issue in order to install the newest AMD graphics drivers on my device. Thanks!

C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,630 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,010 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Bo Balazs 21 Reputation points
    2020-12-27T09:25:40.727+00:00

    I had the exact same problem that's why i'm trying to help all those mates that run into this problem. I found the solution elsewhere. It said to
    Fix problems that block programs from being installed or removed
    https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed
    download troubleshooter button on the link.
    Run it - choose option - have problem with installing - it lists programs - choose the missing / problematic visual c++ runtimes in the list
    it will run and get fixed.
    Repeat for each visual c++ you having problems with. I ran the program multiple times.

    4 people found this answer helpful.

  2. Will V 11 Reputation points
    2020-08-22T22:53:34.023+00:00

    Both the x86 and x64 versions failed to install because I already have it installed on my device.


  3. Artemiy Moroz 271 Reputation points
    2020-09-21T11:33:29.017+00:00

    Hi!
    I would suggest liking MFC and VC++ Runtimes statically. This will eliminate the need to install them each time and make your app more compatible.

    0 comments No comments

  4. Sean Lake 1 Reputation point
    2022-11-05T03:44:44.58+00:00

    Sadly, NONE of these solved my issues. I turned off anything that could block, like CCleaner, etc. I ran things as admin if I could. I ran the MicrosoftProgramInstalUninstall tool, and it didn't resolve the issue. I've been trying to install the latest, 2022 version(s), tried them all, cleaned the registry, stripped every reference to Visual Studio, and STILL, i get this DAM3432!
    C:\ProgramData\Package Cache{3093CC12-EF27-4036-AD72-A759500271E9}v14.29.30040\packages\vcRuntimeMinimum_x86\
    error, still searching for it, and it WON'T get passed it! No matter what version i install!

    It's quite frustrating, as I get to a comment and it looks like something different, but I get the same result. Really lost what to do at this point.


  5. Huskynarr 11 Reputation points
    2022-11-30T14:53:59.637+00:00

    I found a solution:

    Using the Trouble Shooter (Works on Win 11 also):
    https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-removed-cca7d1b6-65a9-3d98-426b-e9f927e1eb4d

    Remove the problematic Visual C++ (in my case all) and install fresh the complete package.
    And now it works for me. Reason was old Visual C++ Package for win 10 mobile developing.

    0 comments No comments