Cannot log in into Azure Portal - Default directory is not available

Mateusz Leszek 26 Reputation points
2022-04-05T13:46:42.787+00:00

Due to the end of work with specific project I've lost the access to the directory that is still set up as the default for my portal. when logging to the azure portal it tries to log me into this directory, which obviously fails. The same happens after clearing cache or using new browser. This causes me to be not able to log in to the Azure Portal at all.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,185 questions
{count} vote

2 answers

Sort by: Most helpful
  1. Mateusz Leszek 26 Reputation points
    2022-04-06T09:41:46.31+00:00

    The problem is solved.

    Problem was that I was a part of tenant that required MFA. My MFA authentication privilege was somehow effectively revoked but I remained a member of the tenant. The tenant was set as a default directory in my Azure Portal. Hence during the login process i was asked to authenticate to the default tenant while out of the reasons above I could not. This prevented me from logging in to portal. I've tried to remove myself from the tenant in https://aad.portal.azure.com/ , but I couldn't due to the lack of MFA authentication :-).

    Solution was to call the organisation managing the problematic tenant and ask them to remove me from the tenant.
    The prefered solution would be though if you could change the default directory without logging in to portal (azure CLI or https://aad.portal.azure.com/) , or some kind of fallback scenario in case you cannot login to the default directory.


  2. JamesTran-MSFT 36,511 Reputation points Microsoft Employee
    2022-05-12T17:11:55.467+00:00

    @Mateusz Leszek
    I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others", I'll repost your solution in case you'd like to "Accept" the answer.

    Solution:

    The problem is solved.

    Problem was that I was a part of tenant that required MFA. My MFA authentication privilege was somehow effectively revoked but I remained a member of the tenant. The tenant was set as a default directory in my Azure Portal. Hence during the login process i was asked to authenticate to the default tenant while out of the reasons above I could not. This prevented me from logging in to portal. I've tried to remove myself from the tenant in https://aad.portal.azure.com/ , but I couldn't due to the lack of MFA authentication :-).

    Solution was to call the organisation managing the problematic tenant and ask them to remove me from the tenant.
    The prefered solution would be though if you could change the default directory without logging in to portal (azure CLI or https://aad.portal.azure.com/) , or some kind of fallback scenario in case you cannot login to the default directory.

    Thank you again for your time and patience throughout this issue.

    ----------

    Please remember to "Accept Answer" if any answer/reply helped, so that others in the community facing similar issues can easily find the solution.

    0 comments No comments