Yammer, Sharepoint, O365-group?

Kjell Brandes 21 Reputation points
2022-04-14T06:48:46.71+00:00

Hi all, I have a Yammer Community that got renamed the other day, after that the Yammer Community "lost" its connection to the previously connected Sharepoint site, so all references to the Sharepoint site where lost?
When selecting the tab named "Files" in Yammer it just delivers an empty section where normally the file area from Sharepoint are shown, also the "Community Resources" area is gone, normally looking like below:
193004-image.png

We are not sure but we think it lost its connection to the Sharepoint site in relation to the renaming of the site.

Looking in Azure at the O365-group I can see that the group is linked to Yammer, but it's missing the expected link to Sharepoint.
192930-image.png

This is how it normally looks in O365 groups created from Yammer:
192879-image.png

Is there any way for me to reconnect the group with the Sharepoint site?
The Sharepoint site is still there and it believes it has been created from Yammer when looking at the properties for the site.
Snap from Sharepoint-admin interface:
192995-image.png

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,989 questions
0 comments No comments
{count} votes

Accepted answer
  1. Echo Du_MSFT 17,121 Reputation points
    2022-04-15T02:22:06.71+00:00

    Hello @Kjell Brandes ,

    Welcome to Q&A Forum!

    Great to know that it works now and thanks for sharing the update here.

    By the way, since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others." and according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

    [Yammer, Sharepoint, O365-group?]

    Issue Symptom:

    Yammer community "loses" its connection to the previously connected SharePoint sites after we renamed it.

    Looking at the O365 group in Azure, we can see that the group is linked to Yammer, but it is missing the expected link to Sharepoint. And, the Sharepoint site still exists, and when we looking at the site's properties, it thinks it was created from Yammer.

    Current status:

    Please follow the steps:

    1. Deactivate "New Yammer" and fall back to the old interface where "Community Resources" becomes visible.
    2. Upload the file to the Sharepoint library via the old interface, then switch back to "New Yammer" and the "Community Resources" is visible again.
    3. Navigate to Azure/groups to show the Sharepoint connection

    You could click the "Accept Answer" button for this summary to close this thread, and this can make it easier for other community member's to see the useful information when reading this thread. Thanks for your understanding!

    Thanks,
    Echo Du

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Kjell Brandes 21 Reputation points
    2022-04-14T08:42:31.657+00:00

    Ok, I solved this my self actually.

    Writing it down in case someone else runs in to the same problem.

    I deactivated the "New Yammer" and fell back at the old interface, in that interface the "Community Resources" became visible.
    Uploaded a file to the Sharepoint library via the old interface and after that switched back to "New Yammer" and there they were, the "Community Resources" where visible again.

    Navigating to Azure/groups also presented the Sharepoint connection again:
    193017-image.png

    So now everything works fine for me again :-)