Azure VM - virtual machine agent status is not ready

Henry Wong 16 Reputation points
2022-04-17T09:42:23.79+00:00

Hi,

I am encountering an error on the Azure VM showing virtual machine agent status is not ready.

This cause the installed extension to be unavailable.

Which I am not able to remote into the VM, the azure backup is unable to run and unable to run command through the Azure portal.

I have tried restarting the VM, re-deploying the VM but none of these steps work.

Would appreciate help on how to resolve this error?

Thank you,

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,409 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Henry Wong 16 Reputation points
    2022-04-18T03:29:12.897+00:00

    Hi,

    I manage to resolve the error by restoring the VM backup.

    Restarting the VM does not help with the error.

    I am not able to run powershell, command or remote into the VM.

    1 person found this answer helpful.

  2. Luis Rodriguez 6,196 Reputation points Microsoft Employee
    2022-04-17T15:31:06.127+00:00

    Hi anonymous user

    The first thing to do would be to make sure that the agent is present in the VM and autoupdate works.

    Have you already followed the docs on troubleshooting vm agent not ready issues?

    Windows: https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/windows-azure-guest-agent#troubleshooting-vm-agent-that-is-in-not-ready-status
    Linux: https://learn.microsoft.com/en-us/troubleshoot/azure/virtual-machines/linux-azure-guest-agent#troubleshoot-a-not-ready-status

    I hope this helps!

    ----------

    Please don’t forget to "Accept the answer" and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.


  3. Mark teh 1 Reputation point
    2022-06-10T15:45:43.2+00:00

    Hi, I have the same issue, I solved it by going into terminal using Azure Serial Console (First time would need to create the Account Storage general purpose v1). For my case, I found the error message is "/dev/sda1: UNEXPECTED INCONSISTENCY". I need to run "fsck /dev/sda1 -y" to fix the disk. To fix the error, I follow this tutorial https://ostechnix.com/how-to-fix-busybox-initramfs-error-on-ubuntu/. Hope it would help some of you.

    0 comments No comments