Teams work and school Stuck at "Loading" on Windows 11 Computers

Michael Adams 306 Reputation points
2022-04-21T17:18:16.823+00:00

I have several Windows 11 computers in which the Teams app gets stuck with the message "Loading" when starting up. It seems this issue started when they broke Teams up into two different apps, the home user one, and the "work and school" versions. If doesn't do it on every Windows 11 computers, but I would say nearly half of them.

I have done the following to diagnose:

1) Deleted all Teams applications.
2) Deleted all Teams folders left over in C:\Users{users}\AppData\Roaming, Appdata\Roaming\Microsoft, and \Appdata\Local\Microsoft folders.
3) Run Online Repair for Office 365.
4) Reinstalled Teams.

This procedure fixed the issue on one computer, but did nothing for others. If anyone has any ideas, I would appreciate it.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,372 questions
{count} votes

7 answers

Sort by: Most helpful
  1. Waruna Bandara 41 Reputation points
    2022-09-27T17:38:24.013+00:00

    This worked for me

    1) Close the opened Teams processes from the taskbar (by right Clicking on Icon) or from the Task manager.
    2) Delete everything in "%appdata%\Microsoft\Teams"
    3) Open Teams

    Cheers!

    8 people found this answer helpful.

  2. OECM Support 6 Reputation points
    2022-05-03T19:14:34.063+00:00

    We have the same problem. company wide on all Windows 11 computers. Teams have to be uninstalled and reinstalled in order to work.

    1 person found this answer helpful.
    0 comments No comments

  3. Mustafa Al Oraibi 1 Reputation point
    2022-05-26T08:13:37.98+00:00

    Windows 11 comes by default with installed MS-Teams, which is causing conflict with MS-Teams School or Work, you need to Settings, Apps, Apps and Features, then uninstall the MS-Teams which is coming with windows (probably having different icon, with white symbol). then restart the computer.

    This solution worked with me.

    0 comments No comments

  4. Andrei Skulkin 1 Reputation point
    2022-05-30T07:24:25.047+00:00

    Had a similar issue. Solutions like adding missing registry key and alike - did not work. Reinstalling anything sounds pretty disgusting, so instead I relogged in my organization account in Windows Settings > Accounts > Access work or school. And voilà - everything works fine now. Note - my password wasn't changed or modified. Looks like some sort of auth session just expired and that caused a problem


  5. Darren Smith 1 Reputation point
    2022-08-16T21:09:06.933+00:00

    Cleared registry, removed all traces of - get this - WINDOWS 11 Teams (for Live accounts only), cleared all temp locations, - HANG - repaired Office, removed traces of Office 2016 (yeah it's been a while), disconnected Work/School account, reinstalled Teams... again, re-added Work account - HANG - and again... found corrupt security perms for /Users on C:\Program Files\WindowsApps\MicrosoftTeams_ - disabled inheritance, took ownership and re-added all perms for folder, restart, - HANG - re-installed Teams, set compatibility mode (Windows 8) auto run as Admin...

    BOOM!

    We are back with the Teams App - OMFG.