Inbound connector not use EXO and Enhanced Filtering not working

adam900331 361 Reputation points


I have an on-premise postfix mail server which relay the e-mail to Exchange Online if recipient isn't local mailbox. I have an inbound connector in cloud and enabled the Enhanced Filtering. But when I send an email from externally to the cloud mailbox, the mail is received, but the header include the postfix server public IP address, so the Enhanced Filtering not working.

I notice that the Inbound connector is not use, I checked the connector report and see the following: From the internet without a connector. Why don't use the inbound connector from the postfix server mail?


Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
3,357 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,408 questions
{count} votes

3 answers

Sort by: Most helpful
  1. adam900331 361 Reputation points

    I resolved the issue. When I create the Inbound connector, I stayed check in the: Retain internal Exchange email headers (recommended) option. I unchecked it and the inbound connector and the Enhanced Filtering works correctly.

    1 person found this answer helpful.

  2. Andy David - MVP 120.5K Reputation points MVP

    If you enabled enhanced filtering and SkipLastIP is set to $false, than you need to define the IPs to skip.
    Yours are not set:


    Typically you would set EFSkipLastIP $true

    Did you follow?

    0 comments No comments

  3. adam900331 361 Reputation points

    Hello Andy!

    I set to EFSkipLastIP to true, but the M365 not remove the last IP from the header. I think the Exchange Online skip the inbound connector when the on-premise postfix relay the message to Exchange Online.

    I check the Mail Flow reports on Exchange Online and see:

    I tried to enter the postfix server public IP address in EFSkipIps attribute, but not resolve my problem.

    0 comments No comments