Azure Databricks - scala udfs

Gopinath Rajee 636 Reputation points


I tried to run this widget code and I'm getting the error. I even enabled scala and tried but that did not help either.

Select * from dbsqlengine.regions where regionDescription = getArgument('Region')

Error in SQL statement: SecurityException: Your administrator has forbidden Scala UDFs from being run on this cluster


Azure Databricks
Azure Databricks
An Apache Spark-based analytics platform optimized for Azure.
1,406 questions
{count} votes

Accepted answer
  1. PRADEEPCHEEKATLA-MSFT 59,341 Reputation points Microsoft Employee

    Hello @Gopinath Rajee ,

    Thanks for the question and using MS Q&A platform.

    You may the below method to get the method to get widgets response into the sql queries:


    Hope this will help. Please let us know if any further queries.


    • Please don't forget to click on 130616-image.png or upvote 130671-image.png button whenever the information provided helps you. Original posters help the community find answers faster by identifying the correct answer. Here is how
    • Want a reminder to come back and check responses? Here is how to subscribe to a notification
    • If you are interested in joining the VM program and help shape the future of Q&A: Here is how you can be part of Q&A Volunteer Moderators

0 additional answers

Sort by: Most helpful