2 related issues: Browser: cannot logon to Teams, App: keeps saying 'We ran into a problem... "

BartS 6 Reputation points
2022-06-27T13:31:05.857+00:00

Hi, I have a few related issues in Teams:

  1. my Teams app keeps saying: 'we ran into a problet. Reconnecting...". When I Quit, and reopen it, it works for like 10 minutes and then gives the same issue
  2. When I send a message to someone, it is sent immediately, but when the other person answers, it does not come to me. Sometimes after 30 minutes, I get everything suddenly.
  3. I cannot login into Teams in te webbrowser. It says: "To open the web app, change your browser settings to allow third-party cookies or allow certain trusted domains."

I did everything I found concerning tips like setting the domain in the browser for *.teams.com and so on.
But the reason the 2 problems are related:

  • I logged on with another teams account on my PC, and failed logging in on another PC (where logging on with another account succeeded).
  • I created for test purposes a new O365 account with my firstname.lastname.teams@ourdomain.com and with this new account I could log on in the browser and my app didn't give the error for 2 weeks. It is not easy to use 2 accounts for 1 person.
  • My messages come instantly when people send me something
    An this on the same pc, with the same Teams app. Just logged on with another user.

Did anybody have the same issue? Can I solve this?
Thanks for your help!

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
5,357 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. BartS 6 Reputation points
    2022-06-30T09:59:07.597+00:00

    Hi I think I solved the issue. I created another O365 user, and everything went fine with teams, but it was a pain having 2 users. 1 for mail and agenda, and the other just to use teams.
    So I thought: oke, I will make my second user my primary.
    But because we are developing in Azure, I gave myself in Azure AD a lot of admin rights. And suddenly, I had the same issue with my new user.
    So this is linked to giving 'a role' in Azure AD.

    I tried removing the ones I was sure I didn't need (in a few bulk operations) and tried every time if the issue was solved. And after the second bulk, it suddenly worked again.
    So I did the same with my primary user, and it works also.
    So now I can use my primary user again in the app and the browser!!!!


  2. Kael Yao-MSFT 22,006 Reputation points Microsoft Employee
    2022-06-28T05:30:54.64+00:00

    Hi @BartS

    Here is a link which may be helpful for troubleshooting: Resolve sign-in errors in Teams
    Please follow the suggestions (run diagnostic in Microsoft 365 admin center and SaRA to see if they would detect any issue with the account).

    Besides, please also try cleaning the Teams cache and rerun Teams to see if it can help.
    For browser, please try cleaning the browser cache and cookies.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.