Outlook Calendar List view - Duration field stopped calculating

Matlock67 41 Reputation points
2022-06-30T08:28:00.547+00:00

Hi,

Until a few months ago, if we searched in Outlook's Calendar, it switched to List view and showed us the results. In that view we had the "Duration" field visible and Outlook was calculating the time duration of each appointment.

This has stopped working 2-3 months ago, probably after an Office Update. We have an Office 365 E3 subscription with monthly updates set to On.

Our version at this time is: Microsoft® Outlook® for Microsoft 365 MSO (Version 2206 Build 16.0.15330.20144) 32-bit

Funny thing is that if we just switch to List view without any filtering, it shows the duration of each appointment, normally.

Is there anyway to make it work again in filtered view or is this a bug?

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,737 questions
{count} vote

Accepted answer
  1. Faery Fu-MSFT 15,671 Reputation points Microsoft Vendor
    2022-07-13T02:13:09.397+00:00

    Hi @Matlock67 ,

    Thanks for your feedback above which shared more information and glad to know that your issue is resolved now! Since our forum has the policy that The question author cannot accept their own answer. They can only accept answers by others, and according to the scenario introduced here: Answering your own questions on Microsoft Q&A

    I would make a brief summary of this post so that other forum members could easily find useful information here:

    [Activating lagged copies - Summary]

    Issue Symptom:
    Outlook Calendar List view - Duration field stopped calculating

    Solution:
    Perform an advanced search, then add the duration filed:
    Step1: Search Tools> Advanced Find
    220215-advanced.png
    Step2: Type test in Search for the words box and click on Find Now.
    220244-test.png
    Step2: Right-click on any field and select Field Chooser, drag Duration to add a column.
    220185-choose.png
    220163-drag.png
    Step3: The search is complete:
    220156-search.png
    You could "Accept Answer" for this summary to close this thread, and your action would be helpful to other users who encounter the same issue and read this thread. Thanks for your understanding!


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 additional answers

Sort by: Most helpful
  1. Matlock67 41 Reputation points
    2022-07-04T09:23:45.17+00:00

    Hi again,

    When I just switch calendar to List view, the duration field is calculated normally.
    217343-outlook-screenshot-1.png

    When in the same view I search for e.g. a specific client's appointments, the duration field is blank.

    217238-outlook-screenshot-2.png

    This was working 2-3 months ago.

    1 person found this answer helpful.

  2. Matlock67 41 Reputation points
    2022-07-12T10:12:32.617+00:00

    No, the proposed workaround does not work and this is not the expected behavior since it worked fine until recently and we are 100% sure about this since we used it regularly. An Outlook update probably broke it.

    The only workaround I've found is to perform an advanced search, add the duration field each tine (because it does not remember it) and then perform search. This needs more steps but it still works correctly.

    Let's hope that someone at Outlook team will fix that..

    1 person found this answer helpful.

  3. Mark Borthwick 6 Reputation points
    2022-12-12T09:34:59.163+00:00

    I have the same issue and its driving me nuts. I found you can export the whole calendar to excel adn then see the duration, but its a long way around for something that used to work just fine.

    1 person found this answer helpful.

  4. Bruce Boma 5 Reputation points
    2023-07-28T19:30:40.0866667+00:00

    I recently upgraded to Office 2021 and have the same issue. It always worked in older versions. My messages are also not showing up under the message column.

    1 person found this answer helpful.