Outlook not returning any search results.

Rudolf Amarlapudi 456 Reputation points
2022-07-12T19:54:32.47+00:00

Hello,

We have multiple users reporting problems with conducting searches in Outlook. Staff is using:
Remote Desktop Server (Windows Server 2016)
Outlook Standard 2016
Microsoft Exchange 2016 Standard

We have users that have tested with their own PC, running Outlook Standard 2016.

I have searched for keywords that I know exist. But results just indicate "No matches found".

219959-image.png
219960-image.png

I have taken the following action thus far:

  1. Checked and verified that Service Windows Search is running.
  2. I have reindexed in Outlook. (File | Options | Search | Indexing Options | Index Settings | Delete and rebuild Index.

Not sure what other paths I can pursue. Any recommendations would be welcome.

Regards,
Rudy

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,736 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ChristyZhang-MSFT 19,211 Reputation points Microsoft Vendor
    2022-07-13T01:54:07.727+00:00

    Hi @Rudolf Amarlapudi ,

    Welcome to our forum!

    What's the version of your Outlook 2016? (File > Office Account > About Outlook). Please make sure you have upgraded your Outlook to the latest version.
    And does this issue occur recently? If so, have you done any specific operations before that?

    As far as I know, when searching in the Outlook client, we need to change the search scope to get the correct search results, such as the Current Folder, All Mailboxes, etc. If you set up a search in the current folder, then messages in other folders will not be searched. Please check it.

    On this basis, if you still can't search all the emails, please refer to this article for troubleshooting:
    Outlook search returns no results
    220184-20.png

    In addition, based on my research, I found an article introduced that when users search their online archive mailboxes that are spread over multiple Shard Locations (auto-expanding archives), they don't get accurate results. They either get no results or more results than expected. If it's your issue, please try the workaround in this article: Incorrect or no results when searching auto-expanding archives in Outlook.

    Hope the above help!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.