Cannot connect to my VM

VM_azure user 1 Reputation point
2022-08-22T01:20:30.607+00:00

Hello,

I have a windows virtual machine, it is working fine however, two days ago I cannot connect to my VM using RDP.

I already followed all the suggested solutions that I found such as:
restarting the VM, resetting NIC, resetting RDP configuration, adding inbound rule of RDP port, ......etc

However, the problem is not solved and the message that shown below 233218-connection-problem-2.jpg

Also, I check the firewall setting of my computer to make sure that the Remote desktop app is allowed

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,294 questions
Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,206 questions
Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,391 questions
{count} votes

10 answers

Sort by: Most helpful
  1. VM_azure user 1 Reputation point
    2022-08-22T09:48:26.077+00:00

    I connect before using Bastion but it cost too much and I did not try SSH

    0 comments No comments

  2. srbhatta-MSFT 8,546 Reputation points Microsoft Employee
    2022-08-23T07:45:37.77+00:00

    Hello @VM_azure user ,
    Welcome to Microsoft QnA.

    1. Can you check the boot diagnostics screenshot and are you able to view the VM boot screen?
    2. Are you able to connect to the VM using serial console? You should be able to connect to VM using serial console once you enable boot diagnostics using custom storage account , and you can check for port 3389 using netstat within the VM itself. You will be able to connect to the serial console successfully if and only if there are no boot issues, and the VM has booted up successfully, but there are network connectivity issues due to which rdp is failing.
    3. Can you check if you are able to telnet to the VM on the rdp port(3389) from any other VM on the same network?
    4. Also, can you verify if port 3389 on the VM is in Listening state on not using netstat ?
    5. Also, are you trying to connect to the VM using its public or private IP? If you are connecting via public IP, I am hoping that you have only allowed trusted IPs in Source to connect to the VM, to avoid and brute force rdp attacks on the VM.

    Once you check for the above cases, you will be able to understand where exactly the network connectivity is breaking.
    If all the above cases are working fine, then most likely there is some issue with the Remote Desktop Service itself. You can also check that once you connect to the VM using Serial Console.

    Each scenario has a separate troubleshooting guide in our docs starting from here (you can navigate across the left vertical pane to directly refer to the use case/bucket your issue falls into).

    If you are still unable to figure out the cause, you will have to open a support ticket with the Azure VM Support Team, and they'll be able to help you further by checking logs from backend and circling down on the cause. Hope that helps.

    Please feel free to reach back for any questions, I'll be more than happy to answer. Thanks :)

    ------------------

    If you find the above information helpful, kindly accept as answer or upvote to increase the relevancy of this post.

    0 comments No comments

  3. VM_azure user 1 Reputation point
    2022-08-23T18:33:49.327+00:00

    Hi @srbhatta-MSFT

    1- I checked the boot diagnostics screenshot and I am able to view the VM boot screen.

    2- I used serial console, fill out my credential and test the port 3398 using netstat command and results are shown
    (is their something need to be checked here ?}

    3- I only have one VM so I cannot do this point.

    4- no Listening state ( all of them are established and time wait)

    5- I cannot connect to VM using public and private IP ( for public IP I received the above message). For the private IP, I received this message
    "Remote desktop cannot connect to the remote computer for one of these reasons :

    1. remote access to the server is not enabled.
    2. the remote computer is turned off.
    3. the remote computer is not available on the network.
      Make sure the remote computer is turned on, and connected to the network and that remote access is enabled. "

    Before I usually connected used public IP and unfortunately the setting for the source is (any).

    Regarding to open support ticked, I tried but it is written that I have to pay for this service ? is this true .

    The problem is that I have to pay for storage all of these days that I cannot connect to VM. and also I cannot work on my project that exist on the VM.

    Thank you for your help

    0 comments No comments

  4. Amol Shelar 421 Reputation points
    2022-08-23T19:36:38.587+00:00

    @VM_azure user ,

    Are you trying to access the server from any restricted (firewall enabled) location? If Yes, can you try to access the server from any other location?

    Could you also let us know what steps you performed to reset RDP configuration?

    Also please share the screenshot of NSG rules configured for this VM.

    _AmolShelar

    0 comments No comments

  5. VM_azure user 1 Reputation point
    2022-08-23T21:17:16.683+00:00

    Hi @Amol Shelar
    1- I usually access the VM from my device but it suddenly from 4 days stop working. what are the setting of firewall that should I check?

    2- I mean resetting VM configuration ( Reset password >>> Reset only configuration ))
    also I tried to redeploy the VM , but the problem is not sloved

    3- 234241-rules.jpg

    0 comments No comments