Edit/ Save button not displaying on modern site pages SharePoint 2019 on Premise

HP 21 Reputation points
2022-09-04T13:49:41.75+00:00

Hello,
We have Sharepoint 2019 on-premise, after applying KB5002212 and KB5002211 users were not able to edit exiting site page and not able to save newly created site page. I applied KB5002246 and KB5002245 on test instance that resolved the edit/save site page issue. However, I applied both KB5002246 and KB5002245 on production issue still not resolved. I ran product config wizard twice as some article suggested, the wizard completed successfully and didn't throw any errors, tried Toolpaneview=2&Mode=Edit but still not resolved. I have farm admin and full control over all site collections. This used to work before KB5002212 and KB5002211. Does anyone have suggestion how to resolve this?

Thank You

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,830 questions
0 comments No comments
{count} votes

Accepted answer
  1. Yi Lu_MSFT 17,461 Reputation points
    2022-09-08T09:33:44.217+00:00

    Hi @HP
    I'm glad to hear you solve the problem, if you have any issue about SharePoint, you are welcome to raise a ticket in this forum.

    By the way, since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others.". and according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

    Issue Symptom:
    We have Sharepoint 2019 on-premise, after applying KB5002212 and KB5002211 users were not able to edit exiting site page and not able to save newly created site page. I applied KB5002246 and KB5002245 on test instance that resolved the edit/save site page issue. However, I applied both KB5002246 and KB5002245 on production issue still not resolved. I ran product config wizard twice as some article suggested, the wizard completed successfully and didn't throw any errors, tried Toolpaneview=2&Mode=Edit but still not resolved. I have farm admin and full control over all site collections. This used to work before KB5002212 and KB5002211.

    Current status:
    Eventually the problem was resolved itself out.

    You could click the "Accept Answer" button for this summary to close this thread, and this can make it easier for other community member's to see the useful information when reading this thread. Thanks for your understanding!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Yi Lu_MSFT 17,461 Reputation points
    2022-09-05T02:32:00.427+00:00

    Hi @HP
    1.You could confirm that whether these pages have been checked out by others. If the pages are checked out, you will not see the Edit button.

    2.You could try to append "?Mode=Edit" to the end of the URL of the page in question (if "?ToolPaneView=2&Mode=Edit" didn't work in your case).


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.