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Teams Rooms app doesn't start automatically after a Windows update

Symptoms

After Windows updates are installed on a Teams Rooms device and the system restarts, the Microsoft Teams Rooms app doesn't start automatically.

Cause

The issue occurs because Windows Update installs an unsupported version of Windows on the device.

Resolution

To fix this issue, follow these steps:

  1. Switch to admin mode, open an elevated Command Prompt window, and then run the following PowerShell command to collect logs:

    powershell -ExecutionPolicy unrestricted c:\rigel\x64\scripts\provisioning\ScriptLaunch.ps1 CollectSrsV2Logs.ps1
    
  2. Locate the .zip log file in C:\rigel that has a filename that resembles SRSv2-<Device Name>-<DateTime>.zip.

  3. Open the .zip file, and then locate and open the MSInfo32.txt file.

  4. Compare the OS Name and Version values with the versions of Windows 10 that support Teams Rooms to verify that an unsupported version of Windows is installed.

  5. Use the Microsoft Teams Rooms recovery tool to restore the device to a supported state. You can use the recovery tool only on supported devices.

    Note

    If any update policies are still applied to the device after you run the recovery tool, the issue might recur when the device restarts unexpectedly because the update policies force the device to reinstall the problematic update. To prevent this, it's important to review and modify the update policies after the recovery process. For more information about how to manage Windows updates for Teams Rooms devices by using Group Policy, Intune, or Configuration Manager, see Manage Windows Updates and Windows 10 release support. Alternatively, consider excluding these devices from your Windows Update management.

More information

To check whether Windows updates are being applied to Teams Rooms devices, use the logs that are generated by the tool that's used to manage Windows updates in your organization. For more information about Windows Update log files and how to troubleshoot Windows Update issues, see the following articles: