(Advanced) and (API access) do not appear in the SharePoint Online Modern admin center
Symptoms
The Advanced and API Access options don't appear in the navigation pane of the SharePoint Online Modern admin center.
Cause
These options may not be available if an app catalog site isn't created or is incorrectly registered on the tenant.
Resolution
To resolve this issue, follow these steps:
Go to the admin center, and select More features.
Under Apps, select Open.
Select App Catalog, and then select Create a new app catalog site. Enter the necessary information, including title, URL, and administrator, as appropriate.
Note
If you have already created an app catalog site, proceed to step 7.
Copy the URL of the app catalog site, and save it to a separate location (such as Notepad, a Word doc, or another program).
Wait for the site to finish provisioning. Note: This process may take up to 10 minutes.
After the site is provisioned, return to the Apps page, and then select App Catalog.
Select Enter a URL for an existing app catalog site, and paste the URL of the app catalog site that you just created.
Note
The site may take up to 20 minutes to complete the registration process.
After the site is registered as an app catalog, return to the SharePoint Modern admin center. You can now see both the Advanced and API access options.
More information
For more information about the app catalog feature, see the following articles:
- Use the App Catalog to make custom business apps available for your SharePoint environment
- Manage access to Microsoft Entra ID-secured APIs
Still need help? Go to Microsoft Community.