Edit

Share via


VM startup is stuck on "Applying Software Installation policy"

Applies to: ✔️ Windows VMs

This article discusses an issue that causes a Microsoft Azure virtual machine (VM) to get stuck during startup on the Applying Software Installation policy screen.

Symptoms

A Windows VM doesn't start. When you use Boot diagnostics to view the screenshot of the VM, you see that the Windows operating system displays the message, Applying Software Installation policy.

Screenshot of Windows operating system displaying the message 'Applying Software Installation policy'.

Cause

Further investigation is required to determine the specific cause of this issue.

Collect memory dump for troubleshooting

If you experience this error, collect an OS memory dump file and then create a support request for Azure support to troubleshoot and diagnose the issue.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.