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This article addresses an issue where the enhanced outbound dialer experience doesn't display all available phone numbers associated with contacts or accounts in Dynamics 365 Customer Service.
Symptoms
When you use the enhanced outbound dialer in Dynamics 365 Customer Service, only the business phone number is displayed for contacts or accounts. Other phone numbers, such as those entered in the mobile phone field, aren't shown, even if they're available in the system.
Cause
This issue might be caused by customizations on the Contact form. Specifically, if a custom mobile phone field has been created, it might not populate the standard mobilephone
attribute of the contacts
entity. As a result, the enhanced outbound dialer retrieves and displays only the business phone number.
Resolution
To resolve this issue, follow these steps:
- Open the Dynamics 365 Customer Service environment.
- Navigate to the Contacts entity and open the Contact form.
- Check for any custom mobile phone fields that have been added to the form.
- Ensure that these custom fields are configured to populate the standard
mobilephone
attribute of thecontacts
entity. - Save and publish the changes to the Contact form.
- Test the enhanced outbound dialer to confirm that it now retrieves and displays all available phone numbers, including mobile numbers.
For more information on the contacts
entity and attributes, see Contact table/entity reference (Microsoft Dataverse).