Follow the instructions in this article to troubleshoot the issues you might face when you work with opportunities.
Opportunity issues and resolution for salespeople
How do I close an opportunity?
Whether your customer has accepted or rejected your proposal, it's a good practice to close the opportunity as won or lost.
When you close an opportunity, the opportunity is marked as complete, and can't be changed. To make further changes to an opportunity, you can reopen it.
Note
At the time of closing the opportunity, enter the Actual Revenue and Actual Close Date. The Actual Revenue is used for reporting purposes in charts and reports in Dynamics 365 Sales.
To close an opportunity, open the opportunity record, and on the command bar, select Close as Won or Close as Lost.
Issue 1 - Can't close an opportunity
Here are some errors you might see when you close an opportunity:
The following sections describe each of these errors and how you can resolve them.
Error 1 - The opportunity can't be closed
Cause
There might be active or draft quotes associated with the opportunity.
Resolution
In the opportunity record, go to the Quotes tab (or Quotes line item tab).
Make sure none of the quotes is in the Draft or Active status.
Error 2 - Access denied or Insufficient permissions
Cause
You don't have sufficient permissions on the opportunity you're trying to close.
Resolution
Ask your system administrator to grant you the necessary permissions.
Error 3 - The opportunity has already been closed
Cause
The opportunity that you're trying to close is already marked as Won or Lost.
Resolution
If you want to make changes to the already closed opportunity, reopen the opportunity, make changes, and close it again.
Issue 2 - Can't edit an opportunity
If you've already closed an opportunity as Won or Lost, it becomes read-only and you can't change it. To make any changes to a closed opportunity, reopen it.
To reopen, open the opportunity, and on the command bar, select Reopen Opportunity.
Issue 3 - Can't add products to an opportunity
Here are some errors you might see when you add products to an opportunity:
In the opportunity record, select the Related tab, and then select Connections.
In the Connections subgrid, select the connection record you added.
Open the connection role selected in the As this role field.
Make sure that Connection Role Category is set to Stakeholder. If it isn't, select Stakeholder in the Connection Role Category drop-down list.
Opportunity pipeline view issues
Issue 1: Pipeline view doesn't display bubbles in the Deal tracker
Cause
There are several reasons why the bubbles might not be visible:
The bubble chart shows only the first 50 valid opportunity entries, meaning those with the defined x-axis, y-axis, radius data, and Segment by fields. This might result in some or all of the bubbles not showing up on the graph despite being present in the grid view.
If the msdyn_Score (opportunity score) and msdyn_Grade (opportunity grade) fields are selected as the Tooltips fields for the Deal tracker, the "not null" filters of these fields will be applied to the opportunities for the bubble chart, potentially filtering out all opportunities from the chart despite being visible in the grid view.
Resolution
To solve this issue, take the following steps:
Ensure that the fields selected for the Deal tracker setting in App Settings on the opportunity pipeline settings page have values for the x-axis, y-axis, radius data, and Segment by fields.
Avoid using the msdyn_Score (opportunity score) and msdyn_Grade (opportunity grade) fields as the Tooltips, x-axis, y-axis, radius, and Segment by fields to ensure the bubbles appear in the Deal tracker. Alternatively, enable predictive opportunity scoring in the organization to populate data for the msdyn_Score and msdyn_Grade fields.
Issue 2: Pipeline view doesn't show all the bubbles in the Deal tracker
The bubble chart is designed to display a maximum of 50 opportunities to maintain clarity of the bubble chart.
Issue 3: Deal manager access privileges are automatically assigned to newly created roles
When an administrator publishes deal manager settings from App Settings on the opportunity pipeline settings page, the prvReadmsdyn_dealmanageraccess and prvReadmsdyn_dealmanagersettings privileges are automatically granted to all newly created roles in the environment.
This behavior is by design. It allows users to read the deal manager settings configuration to display the bubble chart in the pipeline view.
The opportunity management capabilities in Microsoft Dynamics 365 make it easy to manage opportunities and convert more leads. In this module, you'll learn how and when opportunities are used and managed in Dynamics 365. You'll also learn about the options for creating opportunities, their relationships with other records, and how to manage them throughout their lifecycle. By providing a complete view of the customer, Dynamics 365 helps you win more deals.
As a Microsoft Dynamics 365 customer experience analyst, you’re responsible for configuring, customizing, and expanding the functionality of Dynamics 365 Sales to create business solutions that support, automate, and accelerate the company's sales process.