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This article provides a solution to an issue where an appointment is canceled or deleted unexpectedly when you use server-side synchronization in Microsoft Dynamics 365.
Applies to: Microsoft Dynamics 365
Original KB number: 4345686
Symptoms
When you use server-side synchronization to synchronize appointments between Microsoft Dynamics 365 and Exchange, an appointment is canceled or deleted unexpectedly.
Cause
This issue can occur if the appointment no longer meets the conditions of the user's sync filters. As explained in Ignore logically deleted items during synchronization, there are multiple reasons why an appointment no longer matches your sync filters. These reasons include changes to the appointment organizer, the sync filters, and security roles or sharing settings, which cause the user to lose access to the record. By default, server-side synchronization sends a delete operation to Exchange in such scenario, leading to the cancellation of the appointment.
Resolution
As an administrator, you can modify this behavior by changing the DistinctPhysicalAndLogicalDeletesForExchangeSync
setting to True using one of the following tools:
- Organization Settings Editor. For more information about how to use the tool to edit the setting, see Environment database settings.
- OrgDBOrgSettings tool for Microsoft Dynamics 365
By updating this setting, you can manage how deletions are handled during synchronization and prevent unexpected cancellations of appointments.