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This article provides a resolution for error code 8005E274 that occurs when you test and enable a mailbox for server-side synchronization in Microsoft Dataverse.
Symptoms
When a user tries to test and enable a mailbox in Microsoft Dataverse, the test fails with error code 8005E274.
You might also see the following error message in the Alerts section of the mailbox record:
Email Server Error Code: MailboxNotEnabledForRESTAPI
Cause
This issue occurs because the Exchange mailbox associated with the email address isn't enabled for REST API connectivity in the Microsoft 365 tenant relative to the configured email server profile. This issue can occur if the mailbox doesn't have an Exchange Online license, is disabled, or exists in an Exchange on-premises hybrid deployment.
Resolution
Verify that the mailbox has an Exchange online license:
Sign in to the Microsoft 365 portal as an administrator.
Select Users and groups > Active users.
Select Filter (
), and then select Unlicensed users in the drop-down list.
Note
- To assign a license to a user, double-click the user. On the Assign licenses page, select the check boxes next to the items that you want to assign, and then select Save.
- After assigning the Microsoft Dynamics 365 license to the user, this change may take a few minutes to sync between Microsoft 365 and Microsoft Dynamics 365. Exchange might also need additional time to create a mailbox for the user.
Create a hybrid email server profile that points to the on-premises environment:
In the Power Platform admin center, select an environment. On the command bar, select Settings > Email > Server profiles.
On the command bar, select New server profile.
For Email Server Type, select Exchange Server (On Prem), and then specify a meaningful name for the profile.
If you want to use this server profile as the default profile for new mailboxes, turn on Set as default profile for new mailboxes.
If Authentication Type is set to Exchange Hybrid Modern Auth (HMA), enter the location and port for the email server.
Expand the Advanced section, and then use the tooltips to choose your email processing options.
When you're done, select Save.
Test and enable the mailbox again.
- Open the mailbox record if it isn't already open.
- Select the Test & Enable Mailbox button.
- Wait for the "Test & Enable" process to complete. If the test results aren't Success, review the Alerts area within the mailbox record.