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"Mailbox does not have an email server profile or the email server profile is inactive" error when testing a mailbox

This article provides a solution to an error that occurs when you test and enable a mailbox in Microsoft Dynamics 365.

Applies to:   Microsoft Dynamics 365
Original KB number:   4484702

Symptoms

When you try to test and enable a mailbox in Dynamics 365, the test results show as Failure. The following error message is logged in the Alerts section of the mailbox:

Email cannot be received because the mailbox <Mailbox Name> does not have an email server profile associated with it or the email server profile is inactive.
Email Server Error Code: InvalidIncomingEmailServerProfile

Cause

This error occurs if the user's mailbox record in Dynamics 365 lacks a value specified for the Server Profile field or the associated server profile is deactivated.

Resolution

Note

To manage security roles and mailbox settings, you need to sign in to your Dynamics 365 organization as a user with the "System Administrator" role.

  1. Open the mailbox record in Dynamics 365 and verify that a value is selected for the Server Profile field.

  2. If a value is already selected, open the associated server profile and review its Status at the bottom of the page.

  3. If the email server profile shows an Inactive status, follow these steps to activate it:

    1. Navigate to Settings > Email Configuration > Email Server Profiles.
    2. Switch the view to Inactive Email Server Profiles.
    3. Select the email server profile, and then select Activate > OK.
  4. Switch back to the mailbox record, and then select the Test & Enable Mailbox button.

  5. If any test results still show as Failure, check the Alerts section for more information.