Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article provides guidance on resolving an error that occurs when you try to delete records from a custom table in Dynamics 365 Customer Service.
Symptoms
When you try to delete records from a custom table, you receive the following error message:
String or binary data would be truncated.
The error message usually specifies the table and column that cause the truncation error.
Cause
The issue occurs because the data in one or more columns exceeds the maximum allowed character limit for those columns. Specifically, the data length in the affected column(s) is larger than the defined maximum character count.
Resolution
To resolve this issue, follow these steps:
In the left navigation, select Tables, and then select the table where the error occurs.
Select Columns, and locate the problematic column.
Expand Advanced options for the selected column.
Tip
You can also find the Advanced options in the table designer.
Increase the Maximum character count to accommodate the data length.
Save and publish the changes.
After updating the maximum character count, proceed to delete the records again.
If increasing the maximum character count doesn't solve the issue, you can try truncating the data in the column before deleting the records.