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Communication error when launching Power Automate for desktop

This article provides a resolution for a communication error that occurs when you launch or open Power Automate for desktop.

Symptoms

When you launch or open Power Automate for desktop, the following error message shows with a "Communication error" title:

Power Automate console didn't start properly. Restart Power Automate.

Cause

A process may run a WCF-named pipe in the same machine and prevents other WCF-named pipes from working as expected.

This process may run with elevated rights using the localhost endpoint, which blocks other applications from using the endpoint.

Verify the issue

To identify whether there's a WCF-named pipe that uses the localhost endpoint:

  1. Download the SysInternals Suite.

  2. Extract the .zip file to a folder.

  3. Run a command prompt as an administrator.

  4. Navigate to the SysInternals folder that you previously extracted.

  5. Run the following command:

    handle net.pipe
    

    Note

    This command should display a list of processes that use named pipes and the address they listen to.

  6. Identify whether there's a process showing the following string:

    EbmV0LnBpcGU6Ly8rLw==

Resolution

To fix this issue, you should stop the process that causes the issue or, if it's an internal process, configure it to use a more specific endpoint, such as net.pipe://localhost/abc123.

Workaround

To work around this issue, run Power Automate for desktop as an administrator.

Note

  • Running processes as an administrator may cause User Account Control (UAC) prompts to appear each time you launch them.
  • Running Power Automate for desktop as an administrator doesn't work on unattended mode.