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The "Retrieve email messages from Outlook" action doesn't work as expected

This article solves an issue where the Retrieve email messages from Outlook action doesn't return any results in Microsoft Power Automate.

Symptoms

When you use the From contains filter in the Retrieve email messages from Outlook action in Power Automate, no results are returned.

Cause

In some cases, the email addresses of Exchange users are in an X500 format (for example, /o=<organization-name>/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=<mailbox>) instead of the standard mail format (person@email.com). When you use the Retrieve email messages from Outlook action in Power Automate, the From contains filter might not work if the filtering is performed with the X500 format email.

If that's the case, use the X500 format email in the From contains filter.

You can retrieve the X500 format email using the Exchange PowerShell cmdlet:

Get-Mailbox -Identity username | ft legacyExchangeDN.

Alternatively, you can look in %LocalAppData%\Microsoft\Outlook for an XML file that contains a section called LegacyDn.

Workaround

To work around this issue:

More information

Outlook actions