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This article provides guidance to resolve issues where operations take a long time to run and eventually time out. It describes the settings that can be modified to accommodate longer timeout periods.
Symptoms
When you try to highlight, capture, test a UI element, or interact with UI elements during runtime in Power Automate, the operation might take a significant amount of time and ultimately fail. This issue occurs when interacting with Microsoft Remote Desktop Protocol (RDP) or Citrix applications.
Cause
The default time-out settings in Power Automate might be insufficient. The time-outs might need to be adjusted to accommodate the increased time required for communication between the local and remote environments.
Resolution
To resolve the issue, modify the following keys as needed. For more information about configuring the values, see time-out configuration for UI and browser automation.
Java.Bridge.Client.ReadWriteTimeout
- Use this setting if the target application is Java-based.
- This time-out increases the waiting time for responses from Java applications.
- For remote Java applications (for example, on RDP or Citrix), configure this time-out on the remote machine.
BrowserNativeMessageHost.MessageTimeout and WebExtensionsMessageProxy.SendTimeout
- Use these settings if web automation is used.
- These time-outs increase the maximum waiting time for webpages to respond.
- For webpages in remote environments (for example, RDP or Citrix), configure these time-outs on the remote machine.
RDP.Client.CallTimeOut
- Use this setting when interacting with applications or webpages on a remote machine via RDP or Citrix.
- This time-out increases the maximum waiting time for responses from remote applications or webpages.
Other time-out settings
Depending on whether the issue occurs during design time or runtime, the following time-out settings might need to be configured:
For design-time issues (for example, failing to capture an element from the designer), adjust the following setting:
- AutomationServerEndpoint.DesignTime.CallTimeout: This setting increases the time the Power Automate Designer waits for a response.
For runtime issues (for example, failing during the execution of a flow), adjust the following setting:
- AutomationServerEndpoint.Runtime.CallTimeout: This setting increases the maximum waiting time during runtime for an action to be executed.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.