Visual Studio subscriptions – Why do I see personal accounts for my subscribers?
After companies migrated from the Volume Licensing Service Center (VLSC) to the new Visual Studio Subscriptions Admin Portal, admins were surprised to find that the “Sign-in Email Address” for some subscribers shows a personal email address like Hotmail or Outlook.
Cause
This scenario occurs due to sign-in processes that were associated with the legacy MSDN subscriber experience. Users were migrated from the Volume License Service Center (VLSC) to the Visual Studio Subscriptions Admin Portal without modifications. Admins might not know that users are using personal accounts to access their subscription benefits. Before the Visual Studio subscriber migrations, which were completed in 2016, there were two actions required to successfully use a Visual Studio Subscription:
- The admin “assigned” the subscription to an individual subscriber, using their work or school email address.
- The subscriber “activated” the subscription.
During the subscriber activation process, a Microsoft Account (MSA) was required to sign-in. If the subscriber didn’t attempt to make their work or school account (example: tasha@contoso.com
) an MSA, they could create a new MSA or use an existing one. Use of a personal email resulted in their “Sign-in Email Address” being different than their “Assigned to Email Address."
Note
The modern subscriber experience on https://my.visualstudio.com supports both Work/School and Microsoft Account (MSA) identity types.
Solution
To correct the problem, select the Connect Emails button. The system attempts to match the accounts with MSAs to existing users in your organization’s Microsoft Entra ID based on matching the first and family name. If there's an error, you can remove any match by selecting the X to the right of the match.
Watch this video or keep reading to learn how to fix this problem.
You can also use the Search Directory to correct the errors or fill in missing information from your Microsoft Entra ID. If the all the matches look correct, you can choose the Current identity button to select all matched entries rather than selecting them one at a time.
Next select on Continue which takes you to a list of the changes to take place. If you agree, select Save and the changes are made. Your subscriber will also get a message informing them of the change the next time they sign in to their subscription. Notice that only the two subscribers that were matched in the Microsoft Entra ID appear in this list. In our example, since Frederick didn't have a corresponding address in the Microsoft Entra ID, the Microsoft account (MSA) wasn't matched to a work account.
Note
When you edit the sign in email address this only updates the email used by the subscriber to sign in to their subscription on https://my.visualstudio.com. If the subscriber has already activated benefits such as Azure or Pluralsight using the other email address, they will need to continue to use those email addresses to access them. For any new benefits that they access, they should use the new email address.
Support resources
For assistance with administration of Visual Studio Subscriptions, contact Visual Studio subscriptions support.
See also
- Visual Studio documentation
- Azure DevOps Services documentation
- Azure documentation
- Microsoft 365 documentation
Next steps
- If you update the subscribers' email addresses, you might want to notify them that their sign-in information changed. They receive an email with the updated information.
- It might be useful to filter the list of subscribers in your organization to look for any sign in email addresses that might need to be changed.