Creación de la primera función de Java en Azure mediante IntelliJ

En este artículo se muestra cómo usar Java e IntelliJ para crear una función de Azure.

En concreto, en este artículo se muestra:

  • Cómo crear una función de Java desencadenada por HTTP en un proyecto de IntelliJ IDEA.
  • Los pasos necesarios para probar y depurar el proyecto en el entorno de desarrollo integrado (IDE) en su propio equipo.
  • Las instrucciones para implementar el proyecto de función en Azure Functions

Prerrequisitos

Instalación del complemento e inicio de sesión

Para instalar Azure Toolkit para IntelliJ e iniciar sesión, siga estos pasos:

  1. En el cuadro de diálogo Settings/Preferences (Configuración y preferencias) de IntelliJ IDEA (Ctrl+Alt+S), seleccione Plugins (Complementos). A continuación, busque Azure Toolkit for IntelliJ en Marketplace y haga clic en Instalar. Una vez instalado, haga clic en Restart (Reiniciar) para activar el complemento.

    Complemento Azure Toolkit for IntelliJ en Marketplace.

  2. Para iniciar sesión en la cuenta de Azure, abra la barra lateral de Azure Explorer y haga clic en el icono Azure Sign In [Inicio de sesión de Azure) en la barra de la parte superior (o en el menú IDEA, seleccione Tools (Herramientas) > Azure > Azure Sign in (Inicio de sesión de Azure)].

    El comando de inicio de sesión en Azure IntelliJ.

  3. En la ventana Azure Sign In (Inicio de sesión en Azure), seleccione OAuth 2.0 y, luego, haga clic en Sign in (Iniciar sesión). Para ver otras opciones de inicio de sesión, consulte el artículo en el que se proporcionan las Instrucciones de inicio de sesión del kit de herramientas de Azure para IntelliJ.

    La ventana Inicio de sesión de Azure con el inicio de sesión de dispositivo seleccionado.

  4. En el explorador, inicie sesión con su cuenta y vuelva a IntelliJ. En el cuadro de diálogo Select Subscriptions (Seleccionar suscripciones), haga clic en las suscripciones que desea usar y, después, haga clic en Select (Seleccionar).

    Cuadro de diálogo Seleccionar suscripciones.

Creación del proyecto local

Para usar Azure Toolkit for IntelliJ para crear un proyecto local de Azure Functions, siga estos pasos:

  1. Abra el cuadro de diálogo de bienvenida de IntelliJ IDEA, seleccione New Project (Nuevo proyecto) para abrir el asistente para un nuevo proyecto y seleccione Azure Functions.

    Creación de un proyecto de función.

  2. Seleccione Http Trigger (Desencadenador de HTTP), haga clic en Next (Siguiente) y siga el asistente para recorrer todas las configuraciones de las páginas siguientes. Confirme la ubicación del proyecto y haga clic en Finish(Finalizar). Luego, Intellj IDEA abrirá el nuevo proyecto.

    Finalización de la creación de un proyecto de función.

Ejecución del proyecto de forma local

Para ejecutar el proyecto localmente, siga estos pasos:

Importante

Debe tener la variable de entorno JAVA_HOME establecida correctamente en el directorio JDK que se usa durante la compilación de código mediante Maven. Asegúrese de que la versión del JDK sea al menos tan alta como la configuración de Java.version.

  1. Vaya a src/main/java/org/example/functions/HttpTriggerFunction.java para ver el código generado. Junto a la línea 24, observará que se encuentra el botón verde Run (Ejecutar). Haga clic en él y seleccione Run 'Functions-azur...' (Ejecutar "Functions-azur..."). Verá que la aplicación de funciones se ejecuta localmente con algunos registros.

    Proyecto de ejecución local.

    Salida del proyecto de ejecución local.

  2. Para probar la función, acceda al punto de conexión que se muestra desde el explorador; como por ejemplo, http://localhost:7071/api/HttpExample?name=Azure.

    Resultado de la prueba de la función de ejecución local.

  3. El registro también se muestra en IDEA. Para detener la aplicación de funciones, haga clic en el botón Stop (Detener).

    Registro de la prueba de la función de ejecución local.

Depuración del proyecto de forma local

Para depurar el proyecto localmente, siga estos pasos:

  1. Seleccione el botón Depurar en la barra de herramientas. Si no ve la barra de herramientas, seleccione View>Appearance>Toolbar (Ver > Apariencia > Barra de herramientas) para habilitarla.

    Botón de aplicación de funciones de depuración local.

  2. Haga clic en la línea 31 del archivo src/main/java/org/example/functions/HttpTriggerFunction.java para agregar un punto de interrupción. Vuelva a acceder al punto de conexión http://localhost:7071/api/HttpTrigger-Java?name=Azure y verá que se alcanza el punto de interrupción. Después, puede probar más características de depuración, como Step, Watch y Evaluation. Para detener la sesión de depuración, haga clic en el botón Stop (Detener).

    Punto de interrupción de la aplicación de funciones de depuración local.

Implementación del proyecto en Azure

Para implementar el proyecto en Azure, siga estos pasos:

  1. Haga clic con el botón derecho en el proyecto en el explorador de proyectos de IntelliJ y seleccione Azure -> Deploy to Azure Functions (Azure -> Implementar en Azure Functions).

    Implementación del proyecto en Azure.

  2. Si aún no tiene ninguna aplicación de funciones, haga clic en + en la línea Function. Escriba el nombre de la aplicación de funciones y elija la plataforma adecuada. Aquí puede aceptar el valor predeterminado. Haga clic en OK (Aceptar) y la nueva aplicación de funciones que ha creado se seleccionará automáticamente. Haga clic en Run (Ejecutar) para implementar las funciones.

    Creación de una aplicación de funciones en Azure.

    Implementación de una aplicación de funciones en el registro de Azure.

Administración de aplicaciones de funciones desde IDEA

Para administrar las aplicaciones de funciones con Azure Explorer en IDEA, siga estos pasos:

  1. Haga clic en la aplicación de funciones y verá todas las aplicaciones de funciones enumeradas.

    Visualización de aplicaciones de funciones en el explorador.

  2. Haga clic para seleccionar una de las aplicaciones de funciones y, después, haga clic con el botón derecho Show Properties (Mostrar propiedades). Selecciónelo para abrir la página de detalles.

    Mostrar las propiedades de una aplicación de funciones.

  3. Haga clic con el botón derecho en la aplicación de funciones HttpTrigger-Java y seleccione Trigger Function in Browser (Desencadenar función en el explorador). Verá que el explorador se abre con la dirección URL del desencadenador.

    Captura de pantalla que muestra un explorador con la dirección URL.

Adición de más funciones al proyecto

Para agregar más funciones a su proyecto, siga estos pasos:

  1. Haga clic con el botón derecho en el paquete org.example.functions y seleccione Nuevo -> Clase de función de Azure.

    Entrada de la adición de funciones al proyecto.

  2. Escriba HttpTest en el nombre de la clase, seleccione HttpTrigger en el asistente para crear clases de función y haga clic en OK (Aceptar) para crearla. De esta manera, puede crear tantas nuevas funciones como desee.

    Captura de pantalla que muestra el cuadro de diálogo Crear clase de función.

    Salida de la adición de funciones al proyecto.

Limpieza de funciones

Seleccione una de las aplicaciones de funciones mediante Azure Explorer en IDEA y, después, haga clic con el botón derecho y seleccione Delete (Eliminar). Este comando puede tardar varios minutos en ejecutarse. Cuando haya terminado, el estado se actualizará en Azure Explorer.

Captura de pantalla que muestra la opción Eliminar seleccionada en un menú contextual.

Pasos siguientes

Ha creado un proyecto de Java con una función desencadenada por HTTP, lo ha ejecutado en la máquina local y lo ha implementado en Azure. Ahora, amplíe la función, para lo que debe leer el siguiente artículo: