La búsqueda híbrida no puede rastrear o devolver resultados

Síntomas

Experimenta uno o varios de los siguientes problemas al usar la búsqueda híbrida en SharePoint en Microsoft 365:

  • Se produce un error en el rastreo.
  • No se devuelve ningún resultado.
  • Recibe un mensaje de error, como "Una conexión existente se cerró por la fuerza".

Causa

Hemos empezado a desuso de TLS 1.1 y 1.0 en Microsoft 365. A partir del 30 de junio de 2021, el servicio Search ya no aceptará conexiones que usen TLS 1.1 o 1.0. Si usa la aplicación de servicio Search en la nube (SSA) en versiones anteriores de Windows, debe habilitar manualmente TLS 1.2 para que el contenido local se indexe en SharePoint en Microsoft 365.

Solución

Para solucionar este problema, habilite TLS 1.2 siguiendo estas instrucciones:

Nota:

Si sigue experimentando estos problemas en Windows Server 2012 o Windows Server 2008 R2 SP1, pruebe las soluciones siguientes:

Además, compruebe el criterio de ordenación de los conjuntos de cifrado y los conjuntos de cifrado admitidos. Para TLS 1.2, Azure Front Door admite los siguientes conjuntos de cifrado:

  • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
  • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256

Para agregar conjuntos de cifrado, implemente una configuración de directiva de grupo o use la directiva de grupo Editor local, como se describe en Configuración del orden del conjunto de cifrado TLS mediante directiva de grupo.

Importante

Cambie el orden de los conjuntos de cifrado para asegurarse de que estos cuatro conjuntos están en la parte superior de la lista (la prioridad más alta).

Para obtener más información, consulte ¿Cuáles son los conjuntos de cifrado actuales compatibles con Azure Front Door?

Referencias

¿Aún necesita ayuda? Visite Comunidad de SharePoint.