Compartir a través de


Una máquina virtual de Azure que ejecuta un kernel de Linux anterior no se puede reiniciar o aprovisionar

Se aplica a: ✔️ Máquinas virtuales Linux

Número de KB original: 4041171

Nota

CentOS al que se hace referencia en este artículo es una distribución de Linux y llegará al final del ciclo de vida (EOL). Tenga en cuenta su uso y planifique en consecuencia. Para obtener más información, consulte Guía de fin de vida de CentOS.

En este artículo se proporciona una solución a un problema en el que la máquina virtual de Azure que ejecuta una versión anterior del kernel de Linux no se puede reiniciar o aprovisionar.

Síntomas

Considere el caso siguiente:

  • Tiene una máquina virtual Linux de Microsoft Azure que ejecuta una de las siguientes distribuciones de Linux.

    Distribución de Linux (distribución) Versión de distribución Versión de kernel
    Ubuntu 12.04 Cualquier versión
    Ubuntu 14.04 < 4.4.0-75
    Ubuntu 16.04 < 4.4.0-75
    SLES 11 Cualquier versión
    SLES 12 < 4.4.59.92.12
    Red Hat Enterprise
    Linux, CentOS,
    Oracle Linux
    < 7.3 < 3.10.0-514
    Red Hat Enterprise
    Linux, CentOS
    < 6.9 < 2.6.32-671
    Debian < con la versión 7 Cualquier versión
    Debian 8 < 4.9
    CoreOS Any < 4.9
  • La máquina virtual se reinicia o se realiza una nueva solicitud de aprovisionamiento de máquinas virtuales.

En este escenario, la máquina virtual deja de responder o se agota el tiempo de espera de aprovisionamiento. Cuando se produce este problema, se registra una entrada similar a la siguiente en el registro serie de Linux:

[5.464091] hv_vmbus: probe failed for device vmbus_3 (-110) 
 [6.027866] hv_storvsc: probe of vmbus_3 failed with error -110

Nota

Esta entrada puede contener información adicional.

Causa

Este problema se produce porque la máquina virtual Linux no se comunica con el host de Azure. Este error de comunicación se produce debido a parámetros de tiempo de hiperllamada incompatibles en los controladores de Hyper-V que existen en kernels de Linux anteriores.

Solución

Para resolver este problema, intente reiniciar manualmente la máquina virtual después de algún tiempo.  Si el problema persiste, vuelva a implementar la máquina virtual en un nuevo nodo de Azure, inicie la máquina virtual y, a continuación, actualice el kernel de Linux mediante las instrucciones siguientes. También debe realizar estos pasos en la imagen personalizada que usa para implementar la máquina virtual.

Distribución de Linux Versión de distribución Versión del kernel que tiene la corrección Instrucciones de actualización
Ubuntu 12.04 Ninguna opción disponible Actualizar a un LTS posterior
Ubuntu 14.x 4.4.0-75 + Ejecute el siguiente comando:
sudo apt-get update && sudo apt-get install linux-virtual-lts-xenial linux-tools-virtual-lts-xenial linux-cloud-tools-virtual-lts-xenial

Ubuntu 16.x 4.4.0-75 + Ejecute el siguiente comando:
sudo apt-get update && sudo apt-get install linux-image-virtual linux-tools-virtual linux-cloud-tools-virtual

SLES 11 No aplicable Actualización a SLES 12
SLES 12 4.4.59.92.12 + Ejecute el siguiente comando:
sudo zypper update kernel-default

Red Hat Enterprise Linux, CentOS, Oracle
Linux
6.x 2.6.32-671+ Ejecute el siguiente comando:
yum -y update kernel

Red Hat Enterprise Linux, CentOS, Oracle
Linux
7.x 3.10.0-514.16+ Ejecute el siguiente comando:
yum -y update kernel

Debian 7 Ninguna opción disponible Actualización a Debian 9
Debian 8 4.9 + Habilite Debian backports y, a continuación, ejecute el siguiente comando:
sudo apt-get update && sudo apt-get install linux-image-amd64 hyperv-daemons

CoreOS Any 4.9 + Siga las instrucciones de Estrategias de reinicio en las actualizaciones.

Más información

Para más información sobre las distribuciones de Linux aprobadas y las tecnologías de código abierto en Azure, consulte Compatibilidad con la tecnología Linux y código abierto en Azure.

Aviso de declinación de responsabilidades sobre la información de terceros

Los productos de otros fabricantes que se mencionan en este artículo han sido creados por compañías independientes de Microsoft. Microsoft no ofrece ninguna garantía, ya sea implícita o de otro tipo, sobre la confiabilidad o el rendimiento de dichos productos.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.