Compartir a través de


Error de parada de Windows - 0x00000074 Información incorrecta de configuración del sistema

Se aplica a: ✔️ Máquinas virtuales de Windows

Este artículo proporciona pasos para resolver problemas en los que Windows no puede arrancar y necesita reiniciarse debido a información errónea de configuración del sistema en una máquina virtual (VM) de Azure.

Síntoma

Cuando utilice Diagnósticos de arranque para ver la captura de pantalla de la máquina virtual, verá que la captura muestra el código de parada de Windows #0x00000074 o BAD_SYSTEM_CONFIG_INFO.

Se produjo un problema con su PC y se debe reiniciar. Puedes reiniciar. Para obtener más información sobre este problema y sus posibles soluciones, visite https://windows.com/stopcode Si llama al servicio de asistencia técnica, facilítele esta información: Código de parada: BAD_SYSTEM_CONFIG_INFO

Captura de pantalla del código de parada de Windows BAD_SYSTEM_CONFIG_INFO.

Causa

El código de parada BAD_SYSTEM_CONFIG_INFO se produce si el SYSTEM hive del registro parece estar dañado. Este error puede deberse a cualquiera de estas razones:

  • El subárbol de registro no se ha cerrado correctamente.
  • La red de registro está dañada.
  • Faltan claves o valores del registro.

Solución

Información general del proceso

Sugerencia

Si tiene una copia de seguridad reciente de la VM, puede intentar restaurar la VM desde la copia de seguridad para corregir el problema de arranque.

  1. Corrija los daños del subárbol.

  2. Activar la consola serie y la recopilación de volcados de memoria.

  3. Reconstruir la máquina virtual.

    Nota:

    Si se produce este error, el sistema operativo (SO) invitado no está operativo. Solucionarás este problema en modo sin conexión.

Corrección de los daños en hive

Siga estos pasos para corregir el subárbol dañado:

  1. Elimine la máquina virtual.

    Importante

    Cuando se le pida que confirme la eliminación de la máquina virtual, asegúrese de borrar la opción Eliminar con máquina virtual asociada al tipo de recurso de disco del sistema operativo.

  2. Conecte el disco del SO como un disco de datos a otra VM (VM de solución de problemas). Para más información, consulte Conexión de un disco de datos administrado a una máquina virtual Windows mediante Azure Portal.

  3. Conéctese a la máquina virtual de solución de problemas.

  4. Seleccione Inicio y luego busque y seleccione Administración de equipos. En el árbol de consola de la aplicación Administración de equipos, seleccione Administración de discos. Asegúrese de que el disco del sistema operativo esté en línea y de que sus particiones tengan letras de unidad asignadas.

  5. En el disco del sistema operativo que adjuntó, vaya a la carpeta \Windows\System32\config . Copie todos los archivos de esta carpeta de copia de seguridad, por si fuera necesaria una reversión.

  6. Seleccione Inicio y luego busque y seleccione Editor del Registro (regedit.exe).

  7. En la aplicación Editor del Registro, seleccione el subárbol HKEY_USERS, seleccione Carga>de archivos de Hive en el menú y, a continuación, cargue el archivo \Windows\System32\config\SYSTEM.

  8. Si el subárbol se carga sin problemas, significa que el subárbol no se cerró correctamente. En esta situación, descargue el subárbol para desbloquear el archivo y corregir el problema.

    Nota:

    Si recibe el siguiente mensaje de error, póngase en contacto con el soporte técnico de Azure:

    No se puede cargar <unidad>:\Windows\System32\config\SYSTEM: Error al cargar el subárbol

  9. Desconecte el disco del sistema operativo de la máquina virtual de solución de problemas. Cree una nueva máquina virtual desde el disco del sistema operativo.

Habilitar la consola serie y la recopilación de volcados de memoria

Recomendado: antes de reconstruir la VM, habilite la consola serie y la recopilación de volcados de memoria siguiendo estos pasos:

  1. Abra una sesión de símbolo del sistema con privilegios elevados como administrador.

  2. Ejecute los siguientes comandos BCDEdit con las opciones /ems y /emssettings:

    Habilitación de la consola serie:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Compruebe que el espacio libre en el disco del sistema operativo es mayor que el tamaño de la memoria (RAM) de la máquina virtual.

    Si no hay suficiente espacio en el disco del sistema operativo, cambie la ubicación donde se creará el archivo de volcado y diríjala a cualquier disco de datos adjunto a la máquina virtual que tenga suficiente espacio libre. Para cambiar la ubicación, sustituya %SystemRoot% por la letra de la unidad del disco de datos, como F:, en los siguientes comandos.

    Para habilitar el archivo de volcado del sistema operativo, ejecute los siguientes comandos cargar, agregar y descargar para implementar la configuración sugerida mediante la herramienta reg:

    Carga del subárbol del Registro desde el disco de SO roto:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Habilitar en ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Habilitar en ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Descarga del disco roto del sistema operativo:

    reg unload HKLM\<broken-system>
    

Reconstruir la VM

Utilice el paso 5 de los comandos de reparación de máquinas virtuales para reconstruir la máquina virtual.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.