Compartir a través de


Los filtros de cola de vistas personales no funcionan correctamente en el servicio al cliente

En este artículo se proporciona una solución para un problema por el que los filtros de cola de vistas personales que creó anteriormente no funcionan correctamente en el servicio al cliente de Microsoft Dynamics 365.

Síntomas

Al usar filtros de vista personal, es posible que encuentre un formato obsoleto de filtros y entidades vinculadas del filtro "Colas de las que soy miembro" y un mensaje de error similar al siguiente:

<No se encuentra la entidad Entity ID> Link con el nombre o el alias S_Internal_<account ID>

Causa

Al crear una vista personal, se guarda en los filtros aplicados en tiempo de ejecución. Un cambio reciente del sistema a la estructura de filtro provocó incompatibilidad con vistas personales que se crearon anteriormente con el filtro Colas de los que soy miembro o Todas las colas seleccionadas. El cambio del sistema se aplicó para corregir un problema por el que la experiencia editar filtros no estaba disponible para las vistas de elementos de cola. Esta corrección se implementó mediante la reestructuración de las colas de las que soy miembro para que las colas se puedan mostrar y usar correctamente en el panel Editar filtros . Debido a este cambio, es posible que los filtros de vista personal que haya creado anteriormente no funcionen correctamente.

Solución

Para resolver este problema y hacer que la vista personal funcione en el filtro avanzado, use cualquiera de los métodos siguientes:

Método 1: Volver a crear la vista

Si el filtro de vista personal es relativamente sencillo, puede ser más rápido y confiable para volver a crear la vista. Antes de eliminar o dejar de usar la vista anterior, asegúrese de probar primero la nueva vista.

Método 2: Corregir la vista

Siga estos pasos para quitar el formato antiguo de los filtros de cola y reemplazarlo por la versión actualizada:

  1. Abra la vista personal en la cuadrícula de elementos de cola.

  2. Si la lista desplegable de colas está establecida en Colas que soy miembro de o Todas las colas, cambie la lista desplegable a una cola específica. Puede usar la cola de usuario predeterminada o cualquier cola única de la que sea miembro (por ejemplo, "<nombre apellido> nombre").

  3. Abra el panel de filtro avanzado y quite las entidades relacionadas con la cola y los grupos de relaciones que faltan.

    Captura de pantalla que muestra las entidades relacionadas y los grupos de relaciones que faltan que se deben quitar.

    Nota:

    Es posible que vea entradas duplicadas para el filtro Tipo igual a privado . Asegúrese de quitar todo el grupo que los contiene.

  4. Seleccione Aplicar y guarde los cambios en la vista actual.

  5. Vuelva a la opción Colas soy miembro de filtro si no se le devolvió automáticamente a la opción y, a continuación, abra el filtro avanzado.

  6. Quite el filtro de cola específico que se aplicó temporalmente a la vista en los pasos 2 y 3.

  7. Seleccione Aplicar y guarde los cambios en la vista actual. La vista ahora se actualiza con el filtro correcto y funcionará correctamente con la experiencia de filtro avanzada.

Más información

Creación y edición de vistas en aplicaciones controladas por modelos