HoloLens (1ª generación) Aspectos básicos 100: Introducción a Unity

Importante

Los tutoriales de Mixed Reality Academy se diseñaron con HoloLens (1ª generación), Unity 2017 y Mixed Reality cascos envolventes en mente. Por lo tanto, creemos que es importante conservar estos tutoriales para los desarrolladores que sigan buscando instrucciones sobre el desarrollo para esos dispositivos. Estos tutoriales no se actualizarán con los conjuntos de herramientas o interacciones más recientes que se usan para HoloLens 2 y es posible que no sean compatibles con las versiones más recientes de Unity. Se mantendrán para que sigan funcionando en los dispositivos compatibles. Se ha publicado una nueva serie de tutoriales para HoloLens 2.

Este tutorial le guiará a través de la creación de una aplicación básica de realidad mixta compilada con Unity.

Compatibilidad con dispositivos

Curso HoloLens Cascos envolventes
Aspectos básicos de realidad mixta (100): Introducción a Unity ✔️ ✔️

Requisitos previos

Capítulo 1: Crear un nuevo Project

Para compilar una aplicación con Unity, primero debe crear un proyecto. Este proyecto se organiza en algunas carpetas, la más importante de las cuales es la carpeta Assets. Esta es la carpeta que contiene todos los recursos que importa desde herramientas de creación de contenido digital como Maya, Max Cinema 4D o Photoshop, todo el código que cree con Visual Studio o su editor de código favorito, y cualquier número de archivos de contenido que Unity crea a medida que se componen escenas, animaciones y otros tipos de recursos de Unity en el editor.

Para compilar e implementar aplicaciones para UWP, Unity puede exportar el proyecto como una solución de Visual Studio que contendrá todos los archivos de código y recursos necesarios.

  1. Iniciar Unity
  2. Seleccione Nuevo paso.
  3. Escriba un nombre de proyecto (por ejemplo, "MixedRealityIntroduction")
  4. Escriba una ubicación para guardar el proyecto.
  5. Asegúrese de que está seleccionado el botón de alternancia 3D .
  6. Seleccione Crear proyecto.

Enhorabuena, ya está configurado para empezar a trabajar con las personalizaciones de realidad mixta.

Capítulo 2: Configuración de la cámara

La cámara principal de Unity controla el seguimiento de la cabeza y la representación estereoscópica. Hay algunos cambios que se deben realizar en la cámara principal para usarlo con realidad mixta.

  1. Seleccionar archivo > nueva escena

En primer lugar, será más fácil diseñar la aplicación si imaginas la posición inicial del usuario como (X: 0, Y: 0, Z: 0). Puesto que la cámara principal realiza el seguimiento del movimiento de la cabeza del usuario, la posición inicial del usuario se puede establecer estableciendo la posición inicial de la cámara principal.

  1. Seleccione Cámara principal en el panel Jerarquía .
  2. En el panel Inspector , busque el componente Transformar y cambie la posición de (X: 0, Y: 1, Z: -10) a (X: 0, Y: 0, Z: 0)

En segundo lugar, el fondo predeterminado de la cámara necesita algo de pensamiento.

Para HoloLens aplicaciones, el mundo real debe aparecer detrás de todo lo que representa la cámara, no una textura skybox.

  1. Con la cámara principal aún seleccionada en el panel Jerarquía , busque el componente Cámara en el panel Inspector y cambie la lista desplegable Borrar marcas de Skybox a Color sólido.
  2. Seleccione el selector de colores de fondo y cambie los valores RGBA a (0, 0, 0, 0)

En el caso de las aplicaciones de realidad mixta destinadas a cascos envolventes, podemos usar la textura predeterminada de Skybox que proporciona Unity.

  1. Con la cámara principal aún seleccionada en el panel Jerarquía , busque el componente Cámara en el panel Inspector y mantenga la lista desplegable Borrar marcas en Skybox.

En tercer lugar, consideremos el plano de recorte cercano en Unity y evitar que los objetos se represente demasiado cerca de los ojos de los usuarios a medida que un usuario se acerca a un objeto o un objeto se aproxima a un usuario.

Para las aplicaciones de HoloLens, el plano de recorte cercano se puede establecer en el HoloLens se recomiendan 0,85 metros.

  1. Con la cámara principal seleccionada en el panel Jerarquía, busque el componente Cámara en el panel Inspector y cambie el campo Plano de recorte cercano del valor predeterminado 0.3 al HoloLens recomendado 0.85.

En el caso de las aplicaciones de realidad mixta destinadas a cascos envolventes, podemos usar la configuración predeterminada que proporciona Unity.

  1. Con la cámara principal aún seleccionada en el panel Jerarquía , busque el componente Cámara en el panel Inspector y mantenga el campo Plano de recorte cercano al valor predeterminado 0.3.

Por último, guardemos nuestro progreso hasta ahora. Para guardar los cambios en la escena, seleccione Archivo > Guardar escena como, asigne el nombre Main a la escena y seleccione Guardar.

Capítulo 3: Configuración del Project Configuración

En este capítulo, estableceremos algunas opciones de configuración del proyecto de Unity que nos ayudarán a dirigirnos al SDK de holographic Windows para el desarrollo. También estableceremos algunos ajustes de calidad para nuestra aplicación. Por último, nos aseguraremos de que nuestros destinos de compilación estén establecidos en Plataforma universal de Windows.

Configuración de calidad y rendimiento de Unity

Configuración de calidad de Unity para HoloLens

Unity quality settings for HoloLens

Dado que mantener una alta velocidad de fotogramas en HoloLens es tan importante, queremos que la configuración de calidad se ajuste para un rendimiento más rápido. Para obtener información de rendimiento más detallada, recomendaciones de rendimiento para Unity.

  1. Seleccione Editar > Project Configuración > calidad.
  2. Seleccione la lista desplegable en el logotipo de Plataforma universal de Windows y seleccione Muy bajo. Sabrá que la configuración se ha aplicado correctamente cuando el cuadro de la columna Universal Windows Platform (Plataforma universal de Windows) y la fila Very Low (Muy baja) estén en color verde.

En el caso de las aplicaciones de realidad mixta destinadas a pantallas ocluidas, puede dejar la configuración de calidad en sus valores predeterminados.

SDK de Windows 10 de destino

SDK de Windows Holographic de destino

Target Windows Holographic SDK

Es necesario informar a Unity de que la aplicación que estamos intentando exportar debe crear una vista inmersiva en lugar de una vista 2D. Para ello, habilitamos la compatibilidad con Virtual Reality en Unity con el SDK de Windows 10.

  1. Vaya a Editar > Project Configuración > Reproductor.
  2. En el panel inspector del reproductor Configuración, seleccione el icono de Plataforma universal de Windows.
  3. Expanda el grupo XR Settings (Configuración de XR).
  4. En la sección Rendering (Representación), active la casilla Virtual Reality Supported (Se admite Virtual Reality) para agregar una nueva lista de SDK de Virtual Reality.
  5. Compruebe que Windows Mixed Reality (Mixed Reality de Windows) aparece en la lista. Si no es así, seleccione el + botón situado en la parte inferior de la lista y elija Windows Mixed Reality.

Nota

Si no ve el icono de Plataforma universal de Windows, compruebe para asegurarse de que ha seleccionado Plataforma universal de Windows compatibilidad con la compilación durante la instalación. Si no, es posible que deba volver a instalar Unity con la instalación correcta de Windows.

Trabajo impresionante al aplicar toda la configuración del proyecto. A continuación, vamos a agregar un holograma.

Capítulo 4: Creación de un cubo

Crear un cubo en el proyecto de Unity es igual que crear cualquier otro objeto en Unity. Colocar un cubo delante del usuario es fácil porque el sistema de coordenadas de Unity está asignado al mundo real, donde un medidor de Unity es aproximadamente un medidor en el mundo real.

  1. En la esquina superior izquierda del panel Jerarquía , seleccione la lista desplegable Crear y elija Cubo de objetos > 3D.
  2. Seleccione el cubo recién creado en el panel Jerarquía .
  3. En el Inspector , busque el componente Transformar y cambie Posición a (X: 0, Y: 0, Z: 2). Esto coloca el cubo a 2 metros delante de la posición inicial del usuario.
  4. En el componente Transformar , cambie Rotación a (X: 45, Y: 45, Z: 45) y cambie Escala a (X: 0,25, Y: 0,25, Z: 0,25). Esto escala el cubo a 0,25 metros.
  5. Para guardar los cambios en la escena, seleccione Archivo > Guardar escena.

Capítulo 5: Comprobación en el dispositivo desde el editor de Unity

Ahora que hemos creado nuestro cubo, es el momento de realizar una comprobación rápida del dispositivo. Puede hacerlo directamente desde el editor de Unity.

Configuración inicial

  1. En el equipo de desarrollo, en Unity, abra la ventana Compilación > de archivos Configuración.
  2. Cambie Plataforma a Plataforma universal de Windows y haga clic en Cambiar plataforma.

Para HoloLens usar la comunicación remota de Unity

  1. En el HoloLens, instale y ejecute holographic Remoting Player, disponible en Windows Store. Inicie la aplicación en el dispositivo y entrará en un estado de espera y mostrará la dirección IP del dispositivo. Anote la dirección IP.
  2. Abra la emulación holográfica XR > de la ventana>.
  3. Cambie el modo de emulación de Ningunoa Remoto a Dispositivo.
  4. En Equipo remoto, escriba la dirección IP de la HoloLens anotada anteriormente.
  5. Haga clic en Conectar.
  6. Asegúrese de que el estado de conexión cambia a verde Conectado.
  7. Ahora puede hacer clic en Reproducir en el editor de Unity.

Ahora podrá ver el cubo en el dispositivo y en el editor. Puede pausar, inspeccionar objetos y depurar del mismo modo que está ejecutando una aplicación en el editor, ya que básicamente es lo que sucede, pero con la entrada de vídeo, audio y dispositivo que se transmite de vuelta y adelante a través de la red entre la máquina host y el dispositivo.

Para otros cascos compatibles con realidad mixta

  1. Conectar los auriculares al equipo de desarrollo mediante el cable USB y el cable hdmi o del puerto de pantalla.
  2. Inicie el portal de Mixed Reality y asegúrese de que ha completado la primera experiencia de ejecución.
  3. En Unity, ahora puede presionar el botón Reproducir.

Ahora podrá ver la representación del cubo en los cascos de realidad mixta y en el editor.

Capítulo 6: Compilación e implementación en el dispositivo desde Visual Studio

Ahora estamos listos para compilar el proyecto para Visual Studio e implementar en nuestro dispositivo de destino.

Exportación a la solución Visual Studio

  1. Abra la ventana Configuración de compilación de > archivos.
  2. Haga clic en Agregar escenas abiertas para agregar la escena.
  3. Cambie Plataforma a Plataforma universal de Windows y haga clic en Cambiar plataforma.
  4. En Plataforma universal de Windows configuración, asegúrese de que el SDK sea Universal 10.
  5. En Dispositivo de destino, deje en Cualquier dispositivo para mostrar oscluido o cambiar a HoloLens.
  6. El tipo de compilación de UWP debe ser D3D.
  7. El SDK de UWP podría dejarse instalado más reciente.
  8. Haga clic en Generar.
  9. En el explorador de archivos, haga clic en Nueva carpeta y asigne a la carpeta el nombre "App".
  10. Con la carpeta Aplicación seleccionada, haga clic en el botón Seleccionar carpeta .
  11. Cuando Unity haya terminado de compilarse, aparecerá una ventana Windows Explorador de archivos.
  12. Abra la carpeta Aplicación en el Explorador de archivos.
  13. Abra la solución de Visual Studio generada (MixedRealityIntroduction.sln en este ejemplo)

Compilación de la solución de Visual Studio

Por último, compilaremos la solución exportada Visual Studio, la implementaremos y probaremos en el dispositivo.

  1. Con la barra de herramientas superior de Visual Studio, cambie el destino de Depurar a Versión y de ARM a X86.

Las instrucciones difieren para la implementación en un dispositivo frente al emulador. Siga las instrucciones que coincidan con la configuración.

Implementación en un dispositivo de realidad mixta a través de Wi-Fi

  1. Haga clic en la flecha situada junto al botón Máquina local y cambie el destino de implementación a Máquina remota.
  2. Escriba la dirección IP del dispositivo de realidad mixta y cambie modo de autenticación a Universal (protocolo sin cifrar) para HoloLens y Windows para otros dispositivos.
  3. Haga clic en Depurar > Iniciar sin depurar.

Por HoloLens, si es la primera vez que se implementa en el dispositivo, deberá emparejar mediante Visual Studio.

Implementación en un dispositivo de realidad mixta a través de USB

Asegúrese de que el dispositivo está conectado a través del cable USB.

  1. Para HoloLens, haga clic en la flecha situada junto al botón Máquina local y cambie el destino de implementación a Dispositivo.
  2. Para seleccionar dispositivos ocluidos conectados al equipo, mantenga la configuración en Equipo local. Asegúrese de que tiene el portal de Mixed Reality en ejecución.
  3. Haga clic en Depurar > Iniciar sin depurar.

Implementación en Emulator

  1. Haga clic en la flecha situada junto al botón Dispositivo y, en la lista desplegable, seleccione HoloLens Emulator.
  2. Haga clic en Depurar > Iniciar sin depurar.

Prueba de la aplicación

Ahora que la aplicación está implementada, intente mover todo el cubo y observe que permanece en el mundo delante de usted.

Vea también