Data gateways are missing in Power Automate
If you can't see one or more of your on-premises data gateways in the Power Automate portal, follow the recommendations in this article to isolate and resolve the issue.
Applies to: Power Automate
Original KB number: 4555609
Symptoms
You can't see one or more of your data gateways on the Gateways page in the Power Automate portal.
Cause
If the region where you installed the on-premises data gateway doesn't match the region where your Power Automate or Power Apps environment is located, you won't be able to view or use that gateway in that environment.
Verify the issue
To verify the issue, first check the region of the environment you're using and ensure you've selected the desired environment in Power Automate. Then, check the region of your on-premises data gateway.
Step 1: Verify the region of your Power Apps environment
Sign in to the Power Platform admin center as an administrator.
Verify the region of the environment you're using.
Sign in to Power Automate and ensure you've selected the desired environment.
Select Gateways in the left navigation pane.
If Gateways isn't visible in the left navigation pane, select More > Discover all, find Gateways under Data, and then pin it to the navigation pane.
If you don't see your gateway, go to step 2 to verify the gateway's region.
Step 2: Verify the region of your gateway
On the computer hosting the gateway, go to the Start menu, search for On-premises data gateway, and launch the app:
On the app's Status page, select Sign in and sign in with the credentials you used when creating the gateway. If you can't remember the credentials, go to the Resolution section.
After signing in, you can see the region of your gateway on the Status page.
Note
The region where your gateway is installed must map to your Power Automate region. To check the mapping of the gateway region to the Power Platform region, see Regions overview for Power Automate.
If the region doesn't match your environment, follow the steps in the Resolution section to resolve the issue. If the region matches your environment, or if the following steps don't resolve the issue, contact Microsoft Power Automate support for further assistance.
Resolution
It's not possible to change the region of a gateway that's already installed. However, you can follow the steps below to reinstall the gateway in a region that matches your Power Automate environment region.
Go to Add or Remove Programs and select On-premises Data Gateway.
Select Uninstall and follow the wizard to uninstall the gateway.
Download and run the latest version of the On-Premises Data Gateway installer. Before installing, see Install an on-premises data gateway for minimum requirements and considerations.
Follow the installation wizard until you reach the step to name the gateway. For detailed installation steps, see Install an on-premises data gateway.
Select the Change Region link.
Select the region matching your Power Apps environment and select Done.
Note
The region where your gateway is installed must map to your Power Automate region. To check the mapping of the gateway region to the Power Platform region, see Regions overview for Power Automate.
Follow the gateway installation wizard until it's complete.
Sign in to Power Automate, and select Gateways in the left navigation pane.
If Gateways isn't visible in the navigation pane, select More > Discover all, find Gateways under Data, and then pin it to the navigation pane.
Check if the gateway appears in the list of gateways. If the gateway is still missing, contact Microsoft Power Automate support for assistance.