Partekatu honen bidez:


"Error de comunicación" y se produce un error en la conexión entre los componentes de Power Automate

Se aplica a: Power Automate

Síntomas

Al intentar iniciar Power Automate, recibe el siguiente mensaje de error:

Error de comunicación:

No se pudo establecer la conexión entre los componentes de Power Automate. Otra aplicación usa una canalización con nombre necesaria. Póngase en contacto con el administrador de TI.

Causa

Este problema puede producirse si hay dos versiones diferentes de Power Automate para escritorio instaladas en el equipo. En este escenario, se instala una versión con el instalador MSI y se instala una versión diferente desde Microsoft Store. Esto podría dar lugar a conflictos entre las dos versiones y es un escenario no admitido.

Solución

En función de la versión de Power Automate para escritorio, siga los pasos siguientes para resolver el problema.

Si la versión del instalador de la Power Automate para escritorio es 2.34.176.23181 o posterior (versión de Microsoft Store 10.0.7118.0 o posterior), siga estos pasos para desinstalar una versión de la aplicación:

  1. Vaya a Aplicaciones deconfiguración>de inicio>Aplicaciones>instaladas.
  2. Busque Power Automate.
  3. Desinstale cualquiera de las versiones de la aplicación.

Si la versión del instalador de la Power Automate para escritorio es anterior a la 2.34.176.23181 (versión de Microsoft Store anterior a 10.0.7118.0), este error podría producirse si otro proceso ejecuta un servidor de canalizaciones con nombre en el mismo equipo. Es probable que este proceso se ejecute con derechos elevados y mediante el punto de conexión localhost. Por lo tanto, el proceso impide que otras aplicaciones usen el punto de conexión.

Para determinar si otro proceso está causando el error, siga estos pasos:

  1. Cierre Power Automate. Use el Administrador de tareas de Windows para comprobar que el proceso de Power Automate ya no se está ejecutando.

  2. Descargue Sysinternals Suite.

  3. Extraiga el archivo comprimido en una carpeta del escritorio.

  4. Abra una ventana elevada del símbolo del sistema.

  5. Vaya a la carpeta en la que extrajo Sysinternals.

  6. Ejecute el siguiente comando:

    handle net.pipe
    

    La ejecución de este comando debe mostrar una lista de procesos que usan canalizaciones con nombre y mostrar la dirección a la que escuchan.

    Captura de pantalla de los resultados del comando handle net.pipe.

  7. Determine si existe un proceso que muestra la cadena EbmV0LnBpcGU6Ly8rLw== .

  8. Si existe este tipo de proceso, detenga el proceso.

  9. Vuelva a iniciar Power Automate.

Para resolver el problema, detenga el proceso que provoca la ejecución del problema. Como alternativa, si el proceso es interno, puede configurarlo para que use un punto de conexión más específico, como net.pipe://localhost/something.

Si estas acciones no son posibles, especifique los ejecutables de Power Automate para que se ejecuten en modo administrativo. Sin embargo, es posible que esta solución no resuelva el problema en todos los casos. Además, esta solución hará que aparezca un mensaje de UAC cada vez que ejecute la aplicación.