Jaa


Yleisen kansion sisältöä ei voi laajentaa tai tarkastella Outlookissa

Oireet

Kun yrität laajentaa yleistä kansiota tai tarkastella yleisen kansion sisältöä Microsoft Outlookissa, näyttöön tulee seuraava virhesanoma:

Kansion näyttäminen ei onnistu. Verkko-ongelmat estävät yhteyden muodostamisen Microsoft Exchangeen.

Syy

Ongelma ilmenee, jos liian moni käyttäjä (yli 2 000) muodostaa yhteyden samaan yleisen kansion postilaatikkoon. Ongelma voi ilmetä seuraavista syistä:

  • Käyttäjien tasapainoton määritys yleisten kansioiden postilaatikoihin. Exchange-algoritmi valitsee oletusarvoisesti yleisen kansion postilaatikon, johon käyttäjä muodostaa yhteyden . Samaan yleisen kansion postilaatikkoon voi olla liian monta käyttäjäyhteyttä, jos vuokraajan järjestelmänvalvojat ohittavat automaattisen yleisen kansion postilaatikon määrityksen.

  • Paljon käytetty yleinen kansio. Raskas käyttö voi aiheuttaa sen, että yleisen kansion sisältöä isännöityyn yleisen kansion postilaatikkoon voidaan muodostaa liian monta yhteyttä.

Ratkaisu

Voit korjata ongelman seuraavasti:

  1. Varmista, että käyttäjien ja yleisten kansioiden postilaatikot on määritetty tasapainoisesti. Toimi seuraavasti:

    1. Määritä niiden käyttäjien määrä, jotka on määritetty kuhunkin hierarkiaa palvelevan yleisen kansion postilaatikkoon. Jos haluat Exchange Online yleisen kansion postilaatikon, suorita seuraavat komennot Exchange Online PowerShellissä:

      $mbxs = Get-EXOMailbox -ResultSize unlimited -Properties EffectivePublicFolderMailbox
      $mbxs | sort EffectivePublicFolderMailbox | group EffectivePublicFolderMailbox
      

      Jos kyseessä on paikallinen yleinen kansio, suorita seuraavat PowerShell-komennot Exchange Management Shellissä (EMS):

      $mbxs = Get-Mailbox -ResultSize unlimited
      $mbxs | sort EffectivePublicFolderMailbox | group EffectivePublicFolderMailbox
      

      Seuraavassa esimerkissä näytetään käyttäjien tasapainotetun määrittämisen komennot yleisten kansioiden postilaatikoihin. Jokaiseen yleisen kansion postilaatikkoon on määritetty lähes sama määrä käyttäjiä. Tasapainotetun kuormituksen ylläpitämistä pidetään parhaana käytäntönä, koska se vähentää todennäköisyyttä, että yhteen yleisen kansion postilaatikkoon on liian monta käyttäjäyhteyttä.

      Count   Name    Group
      -----   ----    -----
      270     pfmbx1  { hross, nitya.patel, rperrera, sthakkar… }
      259     pfmbx2  { aida.kamaria, rflores, qamar.mounir, kcarter… }
      240     pfmbx3  { gabriel.diaz, nihad.samaha, kmclean, veronica.berg… }
      

      Seuraavassa esimerkissä näytetään käyttäjien tasapainottoman määrittämisen komennot yleisten kansioiden postilaatikoihin. Yli 90 prosenttia käyttäjistä on määritetty samaan yleisen kansion postilaatikkoon. Tasapainoton kuormitus lisää todennäköisyyttä, että joillakin käyttäjillä on yhteysongelmia, jos monet käyttäjät yrittävät käyttää kyseistä yleisen kansion postilaatikkoa samoihin aikoihin.

      Count   Name    Group
      -----   ----    -----
      2710    pfmbx2  { fabiopena, robert.anic, epereira, fadila.baz… }
      5       pfmbx3  { elizabeth.garcia, lponos, laura.cunha, joni.shah… }
      
    2. Jos edellisessä vaiheessa olet todennut, että käyttäjien määritys yleisten kansioiden postilaatikoihin on tasapainoton, määritä DefaultPublicFolderMailbox kunkin käyttäjän postilaatikon parametriarvoksi tyhjäarvo. Jos haluat Exchange Online yleisen kansion postilaatikon, suorita seuraava komento Exchange Online PowerShellissä:

      Get-EXOMailbox -ResultSize unlimited | Set-Mailbox -DefaultPublicFolderMailbox $null
      

      Jos kyseessä on paikallinen yleisen kansion postilaatikko, suorita seuraava PowerShell-komento EMS:ssä:

      Get-Mailbox -ResultSize unlimited | Set-Mailbox -DefaultPublicFolderMailbox $null
      

      Kun komento on suoritettu, järjestelmä määrittää automaattisesti yleisen kansion postilaatikon kullekin käyttäjälle kuormituksen tasapainottaman mukaisesti.

  2. Jos organisaatiossasi on paljon käytetty yleinen kansio, johon yli 2 000 käyttäjää saattaa samanaikaisesti käyttää sisältöä, toimi seuraavasti:

    1. Määritä yleisen kansion postilaatikko, joka sisältää paljon käytetyn yleisen kansion sisällön. Suorita seuraava PowerShell-komento:

      Get-PublicFolder -Identity <public folder path and name> | FL ContentMailboxName
      
    2. Hae organisaation yleisten kansioiden postilaatikoiden luettelo yhdessä niiden isännöimien yleisten kansioiden kanssa. Suorita seuraavat PowerShell-komennot:

      $pfs = Get-PublicFolder -Recurse
      $pfs | sort ContentMailboxName | group ContentMailboxName
      

      Seuraavassa esimerkissä näytetään komentojen tuloste:

      Count   Name    Group
      -----   ----    -----
      1       PFMBX   { IPM\_SUBTREE }
      7       PFMBX2  { HeavilyUsedPF, PF2, PF3… }
      2       PFMBX3  { PF4, PF5 }
      2       PFMBX4  { PF6, PF7 }
      

      Huomautus: Jos haluat vain yleisen kansion postilaatikoiden luettelon, suorita seuraava PowerShellin cmdlet-komento:

      Get-Mailbox -PublicFolder
      
    3. Tunnista edellisessä vaiheessa saamastasi luettelosta vähintään kaksi yleisen kansion postilaatikkoa, joissa ei ole paljon käytettyjä yleisiä kansioita. Luo uusia yleisiä kansioita kyseisiin postilaatikoihin, jotta voit isännöidä paljon käytettyä sisältöä. Jos haluat luoda yleisen kansion yleisen kansion postilaatikkoon, suorita seuraava PowerShellin cmdlet-komento:

      New-PublicFolder -Name <public folder name> -Mailbox <public folder mailbox>
      

      Jos esimerkiksi paljon käytetty yleinen kansio on yleisessä kansiopostilaatikossa PFMBX2 ja sinulla on vähemmän paljon käytettyä sisältöä yleisten kansioiden postilaatikoissa PFMBX3 ja PFMBX4, luo yleiset kansiot sinne.

      Huomautus

      Älä luo yleisiä kansioita ensisijaisen hierarkian yleisen kansion postilaatikkoon.

    4. Outlook-työpöytäsovelluksen avulla voit jakaa paljon käytetyn yleisen kansion sisällön uusiin yleisiin kansioihin, jotka loit edellisessä vaiheessa.

  3. Jos ongelma jatkuu edeltävien vaiheiden suorittamisen jälkeen, aiemmin luodut yleisen kansion postilaatikot ovat ehkä ylikuormitettuja, vaikka ne ovat kuormitettuja. Luo tällöin lisää yleisen kansion postilaatikoita. Kun olet luonut yleisen kansion postilaatikot, järjestelmä lataa ne automaattisesti.