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Permission issues in Business Central cloud migration

This article solves permission errors that you might encounter when trying to set up cloud migration in Business Central.

Symptoms

When a user runs the Cloud Migration Setup assisted setup guide, one of the following error messages appears:

  • Operation on target NotifyBusinessCentral failed: Invoking Web Activity failed with HttpStatusCode - '500': A user setting up Cloud Migration does not have enough permissions: either not a Delegated Admin, or a Delegated Admin without a customer consent.
  • You do not have permission to create or run scheduled tasks.

Cause

The user running the cloud migration setup has insufficient permissions.

Resolution

Note

To solve this issue, you need administrator permissions in Business Central.

  • Make sure the user running the setup is assigned the SUPER permission set in Business Central online.
  • If the user running the setup is a delegated administrator, make sure the customer has consented.