Temporary profile error during machine registration
This article provides a resolution for an error that occurs when you try to register a machine using the Power Automate machine runtime application.
Applies to: Power Automate
Original KB number: 5007391
Symptoms
When you try to register a machine using the Power Automate machine runtime application, you receive the following error message:
An error occurred while registering your machine. Power Automate may have not been installed properly. Follow the steps in the learn more sections.
Cause
This issue occurs because the Power Automate for desktop application isn't properly installed due to a previous installation or uninstallation that puts the "NT Service\UIFlowService" user profile in a broken state.
Resolution
To solve this issue,
Uninstall Power Automate for desktop from the machine and make sure the related files, located in C:\Program Files (x86)\Power Automate Desktop, are deleted.
Reset the user profile manually.
Verify the settings of the "UIFlowService" profile:
Open the Registry Editor and go to the key folder:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484
If a second key exists with the
.bak
extension, you can delete it.Go to the location of
ProfileImagePath
.Verify that the UIFlowService folder is present in that directory. By default, it's located in %SystemRoot%\ServiceProfiles.
Modify the
ProfileImagePath
value to point to the existing UIFlowService folder. By default, it should be %SystemRoot%\ServiceProfiles\UIFlowService.
Restart your machine.
Install Power Automate for desktop again.