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Impossible d’établir une connexion RDP à des machines virtuelles Azure car le service client DHCP est désactivé

S’applique à : ✔️ Machine virtuelles Windows

Cet article décrit un problème qui vous empêche de vous connecter à distance à des machines virtuelles (VM) Windows Azure une fois que le service client DHCP est désactivé sur la machine virtuelle.

Symptômes

Vous ne pouvez pas établir une connexion RDP à une machine virtuelle dans Azure, car le service client DHCP est désactivé sur la machine virtuelle. Lorsque vous vérifiez la capture d’écran dans les diagnostics de démarrage du portail Azure, vous voyez la machine virtuelle démarrer normalement et attendre les identifiants dans l’écran de connexion. Vous consultez à distance les journaux des événements dans la machine virtuelle avec l’observateur d’événements. Vous voyez que le service client DHCP n’est pas démarré ou ne parvient pas à démarrer. Voici un exemple de journal :

Nom du journal : système
Source : gestionnaire de contrôle des services
Date : 16/12/2015 11:19:36 AM
ID d’événement : 7022
Catégorie de tâche : aucune
Niveau : erreur
Mots clés : classique
Utilisateur : N/A
Ordinateur : myvm.cosotos.com
Description : le service Client DHCP s’est bloqué au démarrage.

Pour les machines virtuelles Resource Manager, vous pouvez utiliser la fonctionnalité Console d’accès série pour rechercher les journaux des événements 7022 à l’aide de la commande suivante :

wevtutil qe system /c:1 /f:text /q:"Event[System[Provider[@Name='Service Control Manager'] and EventID=7022 and TimeCreated[timediff(@SystemTime) <= 86400000]]]" | more

Pour les machines virtuelles classiques, vous devez travailler en mode HORS CONNEXION et collecter les journaux d’activité manuellement.

Cause

Le service client DHCP ne s’exécute pas sur la machine virtuelle.

Note

Cet article s’applique uniquement au service client DHCP et pas au serveur DHCP.

Solution

Avant de suivre cette procédure, prenez un instantané du disque du système d’exploitation de la machine virtuelle affectée en guise de sauvegarde. Pour plus d’informations, consultez Créer un instantané.

Pour résoudre ce problème, utilisez le contrôle série pour activer DHCP ou réinitialisez l’interface réseau de la machine virtuelle.

Utiliser le contrôle série

  1. Connectez-vous à la console série et ouvrez une instance CMD. ). Si la console série n’est pas activée sur votre machine virtuelle, consultez Réinitialiser l’interface réseau.

  2. Vérifiez si le protocole DHCP est désactivé sur l’interface réseau :

    sc query DHCP
    
  3. Si DHCP est arrêté, essayez de démarrer le service.

    sc start DHCP
    
  4. Interrogez à nouveau le service pour vous assurer qu’il a réussi à démarrer.

    sc query DHCP
    

    Essayez de vous connecter à la machine virtuelle et regardez si le problème est résolu.

  5. Si le service ne démarre pas, utilisez la solution appropriée suivante en fonction du message d’erreur que vous avez reçu :

    Error Solution
    5- ACCÈS REFUSÉ Consultez Le service client DHCP est arrêté en raison d’une erreur d’accès refusé.
    1053 - ERROR_SERVICE_REQUEST_TIMEOUT Consultez Le service client DHCP plante ou se bloque.
    1058 - ERROR_SERVICE_DISABLED Consultez Le service client DHCP est désactivé.
    1059 - ERROR_CIRCULAR_DEPENDENCY Contactez le support pour résoudre rapidement votre problème.
    1067 - ERROR_PROCESS_ABORTED Consultez Le service client DHCP plante ou se bloque.
    1068 - ERROR_SERVICE_DEPENDENCY_FAIL Contactez le support pour résoudre rapidement votre problème.
    1069 - ERROR_SERVICE_LOGON_FAILED Consultez Le service client DHCP échoue en raison d’un échec d’ouverture de session
    1070 - ERROR_SERVICE_START_HANG Consultez Le service client DHCP plante ou se bloque.
    1077 - ERROR_SERVICE_NEVER_STARTED Consultez Le service client DHCP est désactivé.
    1079 - ERROR_DIFERENCE_SERVICE_ACCOUNT Contactez le support pour résoudre rapidement votre problème.
    1053 Contactez le support pour résoudre rapidement votre problème.

Le service client DHCP est arrêté en raison d’une erreur d’accès refusé

  1. Connectez-vous à la console série et ouvrez une instance PowerShell.

  2. Téléchargez l’outil Process Monitor en exécutant le script suivant :

    remove-module psreadline
    $source = "https://download.sysinternals.com/files/ProcessMonitor.zip"
    $destination = "c:\temp\ProcessMonitor.zip"
    $wc = New-Object System.Net.WebClient
    $wc.DownloadFile($source,$destination)
    
  3. Maintenant, lancez une trace procmon :

    procmon /Quiet /Minimized /BackingFile c:\temp\ProcMonTrace.PML
    
  4. Reproduisez le problème en démarrant le service qui génère le message Accès refusé :

    sc start DHCP
    

    Quand il échoue, mettez fin à la trace de Process Monitor :

    procmon /Terminate
    
  5. Récupérez le fichier c:\temp\ProcMonTrace.PML :

    1. Attachez un disque de données à la machine virtuelle.
    2. Utilisez la Console série pour copier le fichier sur le nouveau disque. Par exemple, copy C:\temp\ProcMonTrace.PML F:\. Dans cette commande, F est la lettre de lecteur du disque de données attaché. Remplacez la lettre appropriée par la valeur correcte.
    3. Détachez le lecteur de données et attachez-le à une machine virtuelle fonctionnelle sur laquelle Process Monitor ubstakke est installé.
  6. Ouvrez ProcMonTrace.PML en utilisant Process Monitor sur la machine virtuelle. Ensuite, filtrez surRésultat est ACCÈS REFUSÉ comme dans la capture d’écran suivante :

    Capture d’écran du bouton Filtrer dans le ruban de la boîte de dialogue Filtre du moniteur de processus lorsque vous filtrez par Le résultat est ACCÈS REFUSÉ.

  7. Corrigez les clés de Registre, les dossiers ou les fichiers qui se trouvent dans la sortie. En règle générale, ce problème est lié au fait que le compte de connexion utilisé dans le service ne dispose pas de l’autorisation d’ACL nécessaire pour accéder à ces objets. Pour déterminer l’autorisation d’ACL adaptée au compte de connexion, vérifiez sur une machine virtuelle saine.

Le service client DHCP est désactivé

  1. Rétablissez la valeur de démarrage par défaut du service :

    sc config DHCP start= auto
    
  2. Démarrez le service :

    sc start DHCP
    
  3. Interrogez de nouveau l’état du service pour vérifier que celui-ci est en cours d’exécution :

    sc query DHCP
    
  4. Essayez de vous connecter à la machine virtuelle à l’aide de Bureau à distance.

Le service client DHCP échoue en raison d’un échec d’ouverture de session

  1. Étant donné que ce problème se produit si le compte de démarrage de ce service a été modifié, rétablissez le compte à son état par défaut :

    sc config DHCP obj= 'NT Authority\Localservice'
    
  2. Démarrez le service :

    sc start DHCP
    
  3. Essayez de vous connecter à la machine virtuelle à l’aide de Bureau à distance.

Le service client DHCP plante ou se bloque

  1. Si l’état du service est bloqué sur Démarrage ou sur Arrêt, essayez d’arrêter le service :

    sc stop DHCP
    
  2. Isolez le service sur son propre conteneur « svchost » :

    sc config DHCP type= own
    
  3. Démarrez le service :

    sc start DHCP
    
  4. Si le service ne démarre toujours pas, contactez le support.

Réparer la machine virtuelle en mode hors connexion

Attachez le disque du système d’exploitation à une machine virtuelle de récupération

  1. Attachez le disque du système d’exploitation à une machine virtuelle de récupération.

  2. Établissez une connexion Bureau à distance avec la machine virtuelle de récupération. Vérifiez que le disque attaché est marqué comme étant En ligne dans la console Gestion des disques. Notez la lettre de lecteur affectée au disque de système d’exploitation attaché.

  3. Ouvrez une instance d’invite de commande avec élévation de privilèges (Exécuter en tant qu’administrateur). Ensuite, exécutez le script suivant. Ce script suppose que la lettre de lecteur affectée au disque de système d’exploitation attaché est F. Remplacez la lettre appropriée par la valeur de votre machine virtuelle.

    reg load HKLM\BROKENSYSTEM F:\windows\system32\config\SYSTEM
    
    REM Set default values back on the broken service
    reg add "HKLM\BROKENSYSTEM\ControlSet001\services\DHCP" /v start /t REG_DWORD /d 2 /f
    reg add "HKLM\BROKENSYSTEM\ControlSet001\services\DHCP" /v ObjectName /t REG_SZ /d "NT Authority\LocalService" /f
    reg add "HKLM\BROKENSYSTEM\ControlSet001\services\DHCP" /v type /t REG_DWORD /d 16 /f
    reg add "HKLM\BROKENSYSTEM\ControlSet002\services\DHCP" /v start /t REG_DWORD /d 2 /f
    reg add "HKLM\BROKENSYSTEM\ControlSet002\services\DHCP" /v ObjectName /t REG_SZ /d "NT Authority\LocalService" /f
    reg add "HKLM\BROKENSYSTEM\ControlSet002\services\DHCP" /v type /t REG_DWORD /d 16 /f
    
    reg unload HKLM\BROKENSYSTEM
    
  4. Détachez le disque de système d’exploitation et recréez la machine virtuelle. Ensuite, vérifiez que le problème est résolu.

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