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Erreur d’arrêt de Windows - 0xC000021A processus système d’état terminé

S’applique à : ✔️ Machine virtuelles Windows

Cet article fournit des étapes pour résoudre les problèmes dans lesquels le système d’exploitation rencontre le code d’erreur Stop 0xC000021A. Cette erreur empêche un redémarrage d’une machine virtuelle Azure.

Symptômes

Lorsque vous utilisez les diagnostics de démarrage pour afficher une capture d’écran de la machine virtuelle, la capture d’écran affiche le message suivant indiquant que le système d’exploitation a rencontré une erreur lors du redémarrage :

Votre PC a rencontré un problème et doit redémarrer. Nous collectons simplement quelques informations sur l’erreur et vous pourrez ensuite redémarrer. (## % terminé) Si vous souhaitez en savoir plus, vous pouvez ultérieurement rechercher cette erreur en ligne : 0xC000021a.

Capture d’écran du code d’erreur Stop : #0xC000021A et le message « Votre PC a rencontré un problème et doit redémarrer ».

Cause

L’erreur 0xC000021A signifie STATUS_SYSTEM_PROCESS_TERMINATED.

Cette erreur se produit lorsqu’un processus critique, tel que Winlogon (winlogon.exe) ou le sous-système d’exécution du serveur client (csrss.exe), échoue. Une fois que le noyau détecte que l’un de ces services s’est arrêté, il retourne le code d’erreur STOP 0xC000021A. Cette erreur peut avoir plusieurs causes, notamment :

  • Des fichiers système incompatibles ont été installés.
  • Échec de l’installation d’une mise à jour du Service Pack ou de la base de connaissances.
  • Un programme de sauvegarde utilisé pour restaurer un disque dur n’a pas correctement restauré les fichiers qui ont pu être utilisés.
  • Un programme tiers incompatible a été installé.

Solution 1 : restaurer la machine virtuelle à partir d’une sauvegarde

Si vous avez une sauvegarde récente de la machine virtuelle, vous pouvez essayer de restaurer la machine virtuelle à partir de la sauvegarde pour résoudre le problème de redémarrage.

Solution 2 : collecter le fichier de vidage de mémoire

Si la restauration de la sauvegarde ne résout pas le problème, collectez un fichier de vidage de mémoire afin que le blocage puisse être analysé. Pour collecter le fichier de vidage, consultez les sections suivantes.

Partie 1 : connectez le disque du système d’exploitation à une machine virtuelle de récupération
  1. Prenez un instantané du disque du système d’exploitation de la machine virtuelle affectée en guise de sauvegarde. Pour plus d’informations, consultez l’article Créer un instantané d’un disque dur virtuel.

  2. Attachez le disque du système d’exploitation à une machine virtuelle de récupération.

  3. Utilisez le protocole RDP (Remote Desktop Protocol) pour vous connecter à la machine virtuelle.

  4. Si le disque du système d’exploitation est chiffré, vous devez désactiver le chiffrement avant de passer à l’étape suivante. Pour plus d’informations, consultez l’article Déchiffrer le disque de système d’exploitation chiffré.

Partie 2 : recherchez le fichier de vidage et envoyez un ticket de support
  1. Sur la machine virtuelle de récupération, accédez au dossier Windows dans le disque de système d’exploitation qui est y connecté. Par exemple, si la lettre de lecteur qui est affectée au disque du système d’exploitation attaché est F, accédez à F:\Windows.

  2. Recherchez le fichier memory.dmp, puis envoyez un ticket de support avec le fichier de vidage.

Note

Si vous rencontrez des problèmes lors de la localisation du fichier Memory.dmp , vous pouvez essayer d’utiliser des appels d’interruption non masquable (NMI) dans la console série à la place. Vous pouvez utiliser ces conseils pour générer un fichier de vidage sur incident à l’aide d’appels NMI.

Prochaines étapes

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.