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S’applique à : ✔️ Machine virtuelles Windows
Cet article fournit des étapes pour résoudre les problèmes dans lesquels le système d’exploitation invité (système d’exploitation invité) rencontre un problème et tente de redémarrer votre machine virtuelle Azure. En outre, le message d’erreur suivant s’affiche :
Une exception de thread système n’a pas été gérée.
Symptômes
Lorsque vous utilisez des diagnostics de démarrage pour afficher une capture d’écran de la sortie de la machine virtuelle, vous remarquez que Windows doit redémarrer une fois qu’il retourne un code d’arrêt « SYSTEM THREAD EXCEPTION NOT HANDLED » ou un code d’erreur « 0x0000007E ».
Cause
La cause de ce problème ne peut pas être déterminée tant qu’un fichier de vidage de mémoire n’est pas analysé. Continuez pour collecter le fichier d’image mémoire.
Solution
Conseil
Si vous avez une sauvegarde récente de la machine virtuelle, vous pouvez essayer de restaurer la machine virtuelle à partir de la sauvegarde pour résoudre le problème de redémarrage.
Pour résoudre ce problème, rassemblez un fichier de vidage de mémoire pour l’incident et envoyez le fichier à Support Microsoft. Pour collecter le fichier de vidage, suivez les instructions des sections suivantes.
Partie 1 : connectez le disque du système d’exploitation à une machine virtuelle de récupération
Prenez un instantané du disque du système d’exploitation de la machine virtuelle affectée en guise de sauvegarde. Pour plus d’informations, consultez l’article Créer un instantané d’un disque dur virtuel.
Attachez le disque du système d’exploitation à une machine virtuelle de récupération.
Utilisez le protocole RDP (Remote Desktop Protocol) pour vous connecter à la machine virtuelle.
Si le disque du système d’exploitation est chiffré, vous devez désactiver le chiffrement avant de passer à l’étape suivante. Pour plus d’informations, consultez l’article Déchiffrer le disque de système d’exploitation chiffré.
Partie 2 : recherchez le fichier de vidage et envoyez un ticket de support
Sur la machine virtuelle de récupération, accédez au dossier Windows dans le disque de système d’exploitation qui est y connecté. Par exemple, si la lettre de lecteur qui est affectée au disque du système d’exploitation attaché est F, accédez à F:\Windows.
Recherchez le fichier memory.dmp, puis envoyez un ticket de support avec le fichier de vidage.
Note
Si vous rencontrez des problèmes lors de la localisation du fichier Memory.dmp , vous pouvez essayer d’utiliser des appels d’interruption non masquable (NMI) dans la console série à la place. Vous pouvez utiliser ces conseils pour générer un fichier de vidage sur incident à l’aide d’appels NMI.
Prochaines étapes
Contactez-nous pour obtenir de l’aide
Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.