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Microsoft Entra Connect Health affiche d’anciennes informations sur le serveur Microsoft Entra Connect local

Cet article traite d’un problème dans lequel Microsoft Entra Connect Health affiche des informations obsolètes sur le serveur Microsoft Entra Connect local.

Version du produit d’origine : Microsoft Entra ID
Numéro de base de connaissances d’origine : 4053427

Symptômes

Le panneau Intégrité de Microsoft Entra Connect n’affiche plus d’informations à jour (par exemple, des erreurs de synchronisation) sur le serveur Microsoft Entra Connect local. Dans certains cas, le service Microsoft Entra Connect Health Insight qui s’exécute sur le serveur Microsoft Entra Connect plante et génère l’événement d’application Windows suivant :

Log Name: Application
Source : Erreur de l’application
Date : 10/19/2017 8:03:19 AM
ID d’événement : 1 000
Catégorie de tâche : (100)
Niveau : Erreur
Mots clés : Classique
Utilisateur : N/A
Ordinateur : XXXXXXX
Description : Nom de l’application défaillante : Microsoft.Identity.AadConnect.Health.AadSync.Host.exe, version : 3.0.68.0, horodatage : 0x5965450e nom du module d’erreur : ntdll.dll, version : 6.3.9600.18696, horodatage : 0x59153753 Code d’exception : 0xc0000374 décalage d’erreur : 0x00000000000f1c00 ID de processus d’erreur : 0x624 heure de début de l’application défaillante : 0x01d348d2403fcb09 chemin d’accès de l’application défaillante : C :\Program Files\Microsoft Azure AD Connect Health Sync Agent\Insights\ Microsoft.Identity.AadConnect.Health.AadSync.Host.exe chemin du module d’erreur : C :\Windows\SYSTEM32\ntdll.dll ID de rapport : 7eb31450-b4c5-11e7-80cb-005056ba3ca2 Nom complet du package d’erreur : ID d’application relatif au package défaillant :

Cause

Le problème se produit s’il existe une incompatibilité de version entre le service de synchronisation Microsoft Entra Connect et microsoft Entra Connect Health pour les applications de synchronisation. Ce problème peut se produire si l’un des composants n’a pas été correctement mis à niveau pendant la dernière mise à niveau de Microsoft Entra Connect ou la mise à niveau automatique.

Pour vérifier qu’un serveur Microsoft Entra Connect existant a un problème de compatibilité de version entre les deux applications, procédez comme suit :

  1. Obtenez la version des applications à partir de l’élément Programmes dans Panneau de configuration.

    Capture d’écran de la fenêtre Programmes dans laquelle les informations de version sont affichées.

  2. Comparez les informations de version par rapport au tableau de compatibilité suivant :

    Version du service de synchronisation Version de l’Agent d’intégrité compatible
    1.1.614.0 (ou version antérieure) 3.0.68.0 (ou version antérieure) 3.0.127.0
    1.1.647.0 (ou version ultérieure) 3.0.103.0 3.0.129.0

Résolution

Pour résoudre ce problème, appliquez l’une des méthodes suivantes.

Méthode 1

Mettez à niveau manuellement votre serveur Microsoft Entra Connect vers la version 1.1.649.0 ou une version ultérieure. Pendant la mise à niveau manuelle, les deux applications sont mises à niveau vers les versions compatibles les unes avec les autres.

Pour plus d’informations sur la mise à niveau du serveur Microsoft Entra Connect, consultez l’article Azure suivant : Microsoft Entra Connect : Mettre à niveau à partir d’une version précédente vers la dernière version

Méthode 2

Réinstallez manuellement l’Agent d’intégrité pour la synchronisation vers une version compatible avec la version du service de synchronisation installée sur le serveur Microsoft Entra Connect. Par exemple, vous disposez d’un serveur Microsoft Entra Connect existant qui dispose du service de synchronisation version 1.1.647.0 et de l’agent d’intégrité pour sync version 3.0.68.0. Pour résoudre le problème d’incompatibilité, vous pouvez réinstaller l’Agent d’intégrité pour Sync version 3.0.129.0.

Pour réinstaller l’agent d’intégrité pour la synchronisation :

  1. Déterminez la version de l’Agent d’intégrité compatible avec la version du service de synchronisation Microsoft Entra Connect que vous avez installé. Si vous disposez du service de synchronisation Microsoft Entra Connect version 1.1.647.0 ou ultérieure, utilisez Health Agent Version 3.0.129.0.

  2. Téléchargez une copie du programme d’installation de l’Agent d’intégrité (AadConnectHealthAadSyncSetup.exe) à partir du site web du Centre de téléchargement Microsoft suivant :

    Télécharger et installer Microsoft Entra Connect Health Agent

  3. Connectez-vous au serveur Microsoft Entra Connect à l’aide d’un compte disposant des droits d’administrateur local.

  4. Pour désinstaller la version existante de l’Agent d’intégrité, procédez comme suit :

    1. Accédez à Panneau de configuration> Program et fonctionnalités. Sélectionnez Microsoft Entra Connect Health Agent for Sync, puis désinstallez.

      Note

      La fenêtre d’installation de l’Agent d’intégrité s’ouvre.

    2. Dans la fenêtre d’installation de l’Agent d’intégrité, sélectionnez Désinstaller.
    3. Une fois le processus de désinstallation terminé, sélectionnez Fermer.
  5. Pour installer la version compatible de l’Agent d’intégrité :

    1. Double-cliquez sur le fichier exécutable téléchargé.

    2. Dans l’écran Installation , sélectionnez Installer.

    3. Une fois l’installation terminée, sélectionnez Fermer.

      Important

      Ne sélectionnez pas Configurer.

    4. Démarrez une nouvelle session PowerShell. Inscrivez l’agent d’intégrité installé auprès de Microsoft Entra ID en exécutant l’applet de commande suivante :

      Register-AzureADConnectHealthSyncAgent -AttributeFiltering:$false -StagingMode:$false
      
    5. Lorsque vous êtes invité à entrer des informations d’identification, fournissez vos informations d’identification d’administrateur général Microsoft Entra.

    6. Attendez environ deux heures, puis vérifiez que le panneau Intégrité affiche des informations à jour sur la synchronisation.

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