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UnknownIncomingEmailIntegrationError -2147220891 ou 80040265 apparaît dans les alertes de boîte aux lettres dans Microsoft Dynamics 365

Cet article fournit une solution à une erreur qui se produit dans les alertes de boîte aux lettres dans Microsoft Dynamics 365.

S’applique à : Microsoft Dynamics 365
Numéro de base de connaissances d’origine : 4466423

Symptômes

Lorsque vous affichez la section alertes dans un enregistrement de boîte aux lettres dans Dynamics 365, vous voyez l’un des messages suivants :

  • « Une erreur inconnue s’est produite lors de la réception d’e-mails par le biais de la boîte aux lettres «< Nom> de la boîte aux lettres ». Le propriétaire du profil de profil <> de serveur de messagerie associé a été averti. Le système tente de recevoir un e-mail ultérieurement.

    Code d’erreur du serveur de messagerie : Le serveur Exchange a retourné UnknownIncomingEmailIntegrationError -2147220891 exception. »

  • « Une erreur Microsoft Dynamics 365 interne s’est produite lors de la synchronisation des rendez-vous, des contacts et des tâches pour la boîte aux lettres «< Nom> de la boîte aux lettres ». Le propriétaire du profil de profil <> de serveur de messagerie associé a été averti. Le système réessayera ultérieurement.

    Code d’erreur du serveur de messagerie : Le code Crm.80040265.ISV a abandonné l’opération. »

Cause

Le code d’erreur 80040265 ou -2147220891 indique une erreur IsvAborted.

Si vous voyez le premier message répertorié dans la section Symptômes , il est généralement dû à un flux de travail ou à un plug-in personnalisé qui s’exécute lorsqu’un enregistrement de messagerie est créé.

Si vous voyez le deuxième message répertorié dans la section Symptômes , il est généralement dû à un flux de travail ou à un plug-in personnalisé qui s’exécute lorsqu’un rendez-vous, un contact ou un enregistrement de tâche est créé.

Résolution

Vérifiez si des plug-ins ou workflows personnalisés s’exécutent de manière synchrone lors de la création du type d’enregistrement (e-mail, rendez-vous, contact ou tâche) mentionné dans l’erreur. Si un plug-in ou un workflow provoque une erreur lors de la création de l’enregistrement, la synchronisation côté serveur ne peut pas créer l’enregistrement correctement. Les étapes suivantes peuvent vous aider à identifier s’il existe des flux de travail ou des plug-ins dans votre organisation qui s’exécutent lors de la création d’un e-mail. Utilisez les mêmes étapes pour d’autres entités telles que les rendez-vous et les tâches en remplaçant l’entité par le type d’enregistrement approprié.

Workflow

  1. Dans l’application web Dynamics 365, accédez à Paramètres, puis sélectionnez Processus.

  2. Modifiez l’affichage en processus activés.

  3. Triez sur la colonne Entité principale et recherchez les lignes avec e-mail comme entité principale et flux de travail comme catégorie.

    Au lieu de cela, vous pouvez utiliser les options de filtrage dans la grille pour filtrer sur Category = Workflow and Primary Entity = Email.

  4. Ouvrez chaque flux de travail que vous trouvez répondant aux critères précédents (le cas échéant).

  5. Si l’option Démarrer lorsque l’option Enregistrer est créée est sélectionnée et que l’option Exécuter ce flux de travail en arrière-plan (recommandé) n’est pas sélectionnée, ce flux de travail peut être la cause.

  6. Sélectionnez la section Sessions de processus sur le côté gauche de la page et recherchez les échecs liés à l’e-mail qui n’a pas été créé avec succès.

Plug-in

  1. Dans l’application web Dynamics 365, accédez aux personnalisations des paramètres>, puis sélectionnez Personnaliser le système.
  2. Sélectionnez Étapes de traitement des messages du Kit de développement logiciel (SDK).
  3. Triez sur la colonne Code de type d’objet principal (filtre SdkMessage) et recherchez les lignes de l’entité e-mail .
  4. Si le mode d’exécution de ces lignes est défini sur Synchrone, il peut interférer avec la création de l’e-mail.

Si vous êtes en mesure de reproduire le problème de manière cohérente, vous pouvez essayer de désactiver temporairement le workflow ou le plug-in pour déterminer si le flux de travail ou le plug-in est la cause du problème.