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Cet article fournit une résolution d’un problème où la stratégie de groupe avec des filtres WMI peut être refusée ou provoquer une connexion lente/démarrage.
S’applique à : Windows Server 2008 R2 Service Pack 1
Numéro de la base de connaissances d’origine : 2663850
Symptômes
La stratégie de groupe avec le filtre WMI ne parvient pas à s’appliquer. La requête WMI (filtre WMI lié à un objet de stratégie de groupe) expire en raison de laquelle l’objet de stratégie de groupe ne s’applique pas aux ordinateurs, de façon intermittente.
Les journaux GPSVC indiquent les éléments suivants :
GPSVC(320.af8) <DateTime> FilterCheck : Évaluer l’erreur retournée. hr=0x80041069
GPSVC(320.af8) <DateTime> ProcessGPO : l’objet de stratégie de groupe ne passe pas la vérification du filtre et ne sera donc pas appliqué.
ERR pour 0x80041069 donne le résultat suivant :
# pour le 0x80041069 hexadécimal /décimal -2147217303
WBEM_E_TIMED_OUT wbemcli.h
# en tant que HRESULT : Gravité : FAILURE (1), FACILITY_ITF (0x4), Code 0x1069
# pour le 0x1069 hexadécimal / décimal 4201
ERROR_WMI_INSTANCE_NOT_FOUND winerror.h
# Le nom d’instance passé n’a pas été reconnu comme valide par un fournisseur de données # WMI
# 2 correspondances trouvées pour « 0x80041069 »
Cause
Le filtrage WMI prenait du temps pendant le traitement. Il essayait d’énumérer tous les noms de domaine comme requête utilisée était :
Select * from Win32_NTDomain where ClientSiteName = "XYZ"
Résolution
Ajoutez un composant de nom de domaine à la requête WMI pour résoudre le problème (ainsi que l’opérateur AND) :
Select * from Win32_NTDomain where DomainName = "Domain_name" AND ClientSiteName = "XYZ"
Vérifiez que le correctif logiciel ci-dessous est déjà installé :
Plus d’informations
Délai d’expiration pour les requêtes WMI :
Per-Vista = None
Vista et versions ultérieures = 30 secondes (codées en dur)
Dans l’un des cas, il a été informé que la suppression du filtrage de sécurité personnalisé de l’objet de stratégie de groupe (qui a configuré le filtre WMI) a résolu le problème, mais qu’il n’a pas été testé ou vérifié.
Collecte de données
Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés à l’expérience utilisateur.