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Ouverture de session lente inattendue causée par un grand référentiel WMI dans Windows ou Windows Server

Cet article fournit de l’aide pour résoudre le processus d’ouverture de session lent qui se produit lorsque les utilisateurs se connectent aux serveurs Bureau à distance.

Numéro de base de connaissances d’origine : 2020286

Symptômes

Vous remarquez l’un des symptômes suivants :

  • Le processus d’ouverture de session est inopinément lent lorsque les utilisateurs se connectent aux serveurs Bureau à distance.
  • Les utilisateurs subissent des retards lorsqu’ils se connectent à la console d’un client Windows ou d’un ordinateur Windows Server.

Ce délai est enregistré dans le fichier journal Userenv.log dans Windows Server 2003 et dans le fichier journal Gpsvc.log dans les clients Windows 8.1, Windows 8 et Windows 7 et sur les ordinateurs Windows Server 2012 R2, Windows Server 2012, Windows Server 2008 R2 et Windows Server 2008.

Exemple Userenv.log entrée :

USERENV(234.82c) 08:28:36:210 ParseRegistryFile : Leaving.
USERENV(234.82c) 08:30:26:839 LogRegistry RsopData : Données Rsop de Registre journalisées avec succès

Cet exemple montre un délai d’environ 2 minutes lors de l’écriture de données de journalisation RSoP.

Comment activer la journalisation dans le fichier Gpsvc.log sur les clients Windows 8.1, Windows 8 et Windows 7 et Windows Server 2012 R2, Windows Server 2012, Windows Server 2008 R2 et Windows Server 2008

Pour activer la journalisation dans le fichier Gpsvc.log, procédez comme suit.

Important

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, vérifiez que vous suivez ces étapes attentivement. Pour une protection supplémentaire, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d’informations sur la sauvegarde et la restauration du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft : 322756 Comment sauvegarder et restaurer le Registre dans Windows

  1. Cliquez sur Démarrer, sur Exécuter, tapez regedit& , puis cliquez sur OK.

  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

  3. Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Touche.

  4. Tapez Diagnostics, puis appuyez sur Entrée.

  5. Cliquez avec le bouton droit sur l’entrée Diagnostics , pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  6. Tapez GPSvcDebugLevel, puis appuyez sur Entrée.

  7. Cliquez avec le bouton droit sur GPSvcDebugLevel, puis cliquez sur Modifier.

  8. Dans la zone de données Valeur, tapez 0x30002, puis cliquez sur OK.

  9. Quittez l’Éditeur du Registre.

  10. À l’invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :

    gpupdate /force 
    
  11. Affichez le fichier Gpsvc.log dans le dossier suivant : %windir%\debug\usermode.

    Note

    Si le dossier Usermode n’existe pas sous %WINDIR%\debug\, le fichier Gpsvc.log n’est pas créé. Si le dossier Usermode n’existe pas, créez-le sous %windir%\debug.

Exemple d’entrée Gpsvc.log :

GPSVC(638.13d4) hh :mm :41:316 AllocAdmFileInfo : Ajout du nom <de fichier \\contoso.com\sysvol\contoso.com\Policies\{<policy guid>}\Adm\wuau.adm> à la liste Adm.
GPSVC(638.13d4) hh :mm :47:556 LogRegistry RsopData : L’exemple Rsop dataThis de Registre enregistré avec succès montre un délai ~ 6 secondes lors de l’écriture de données de journalisation RSoP.

Cause

Ce problème peut se produire si la journalisation RSoP est activée et qu’il existe un dépôt WMI volumineux sur le client Windows ou l’ordinateur Windows Server problématique. Le référentiel WMI se trouve sur le chemin d’accès suivant :

%windir%\System32\Wbem\Repository

RSoP utilise la base de données CIMOM via WMI. Lorsqu’un ordinateur se connecte à un réseau, des informations telles que le matériel informatique, les paramètres d’installation du logiciel de stratégie de groupe, les paramètres de maintenance d’Internet Explorer, les scripts, les paramètres de redirection de dossiers et les paramètres de sécurité, sont écrites dans la base de données CIMOM. Lorsque vous démarrez RSoP en mode journalisation, RSoP signale les paramètres de stratégie qui ont été appliqués à l’aide des informations fournies dans la base de données CIMOM.

Le processus de journalisation RSoP vers le référentiel WMI entraîne des retards dans les journaux de console et en particulier les connexions Bureau à distance.

Les tailles de référentiel WMI supérieures dans %windir%\system32\wbem\repository provoquent des retards d’ouverture de session plus longs. Pour plus d’informations sur RSoP, consultez la rubrique Microsoft TechNet suivante :

Vue d’ensemble de RSoP

Solution de contournement

Pour contourner ce problème, déterminez la taille du référentiel WMI.

Le référentiel WMI se trouve sur le chemin d’accès suivant :

%windir%\System32\Wbem\Repository

Si la taille du référentiel WMI est importante, désactivez temporairement la journalisation RSoP pour surveiller son impact sur les connexions utilisateur.

Pour désactiver la journalisation RSoP, activez le paramètre de stratégie de groupe suivant :

Désactiver la journalisation RSoP (Configuration ordinateur/Modèles d’administration/Système/Stratégie de groupe)

Note

Ce paramètre vous permet d’activer ou de désactiver la journalisation du jeu de stratégies résultant (RSoP) sur un ordinateur client.

Après avoir activé cette stratégie, exécutez gpupdate /force sur l’ordinateur, puis redémarrez l’ordinateur. Mesurez l’impact sur la durée de connexion de l’utilisateur.

Note

En désactivant la journalisation RSoP, vous empêchez l’exécution du composant logiciel enfichable RSoP (rsop.msc) sur cet ordinateur. Vous pouvez obtenir des informations de modélisation RSoP à l’aide de la console de gestion des stratégies de groupe (GPMC), si nécessaire.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés à l’expérience utilisateur.