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Le nouvel état de l’imprimante est hors connexion après avoir supprimé une file d’attente d’impression, puis redémarré un ordinateur Windows

Cet article fournit une solution à un problème où le nouvel état de l’imprimante est hors connexion après avoir supprimé une file d’attente d’impression, puis redémarré un ordinateur Windows.

Numéro de base de connaissances d’origine : 2027593

Symptômes

Examinez le cas suivant :

  • Vous supprimez une file d’attente d’impression pendant qu’elle se trouve dans un état hors connexion.
  • Vous ajoutez une nouvelle file d’attente d’impression portant le même nom que l’ancienne file d’attente d’impression.
  • Vous redémarrez l’ordinateur.

Dans ce scénario, l’état de la nouvelle file d’attente d’impression s’affiche en mode hors connexion.

Cause

Ce problème se produit si l’ordinateur a la valeur de Registre suivante configurée lorsque vous définissez l’imprimante sur l’état hors connexion :

Clé : Valeur : HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name> PrinterOnLine
Données : 0

Toutefois, cette valeur n’est pas supprimée par le fichier Localspl.dll lorsque la file d’attente d’impression est supprimée. Par conséquent, lorsque vous ajoutez une file d’attente d’impression portant le même nom que l’ancienne file d’attente d’impression, la nouvelle file d’attente d’imprimante hérite de l’état hors connexion de la file d’attente d’impression supprimée.

Résolution

Pour résoudre ce problème, cliquez avec le bouton droit sur la nouvelle file d’attente d’impression dans l’outil Imprimantes et télécopies, puis désactivez le paramètre Utiliser l’imprimante hors connexion . Cela réinitialise la clé de Registre à la valeur correcte. Au lieu de cela, vous pouvez supprimer la clé de Registre mentionnée dans la section Cause après avoir supprimé une file d’attente d’impression, mais avant d’ajouter une nouvelle file d’attente d’impression du même nom.

A-t-il résolu le problème

  • Vérifiez si le problème est résolu. Si le problème est résolu, vous en avez terminé avec cette section. Si le problème n’est pas résolu, vous pouvez contacter le support technique.
  • Nous aimerions recevoir vos commentaires. Pour fournir des commentaires ou signaler des problèmes avec cette solution, laissez un commentaire en nous envoyant un e-mail .

Collecte de données

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